×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2006
    Posts
    4

    Several problems with NMIT 4.1

    I've installed NMIT 4.1 and had some problems with decent JRE's. I used previously Sun JRE 1.5 and NMIT didn't work out properly. Although, problems got solved when installed JDK 1.4.2_11 and began to start NMIT with earlier JDK. Thought that the battle with these tools were won and could concentrate on services' development. But no..

    1) Still, some problems did stay with NMIT's MMS-properties; if I start NMIT with JDK 1.4 and try to open NMIT's MMS-messaging samples ("MarketUpdate" and "WorldCup", both with and without SMIL), the editor does not open these examples. The NMIT GUI shows only "Loading from stream.." message at the bottom of NMIT's window and nothing else happens ie. the message's "source" does not open for viewing/editing. Paranoid or not; if I launch the NMIT with the newer JDK 1.5, the MMS messages are opened for viewing, but then editing own WML, XHTML, MMS content does not work.....

    2) On the other hand; (NMIT launched w/JDK 1.4) if I create any own MMS-message with NMIT's tools (New.. MMS Message or MMS Wizard), I can really create a new MMS-message, add new content (text, images, etc), but then two major problems occur. Firstly; the PUSH-operation does make no result ie. the message isn't being sent to the phone emulator. The same goes when using any installed emulators. Secondly; saving own MMS-messages does not work; selecting Save.. show the file selection dialog, but no file is really saved.

    Eventually, these problems prevent doing any MMS, SMIL etc. development and thus makes the tool really handicapped.

    As mentioned earlier, I use NMIT version 4.1, JDK version 1.4.2_11 and Nokia Mobile Browser version 4.0 and Series 40 SDK 3rd Edition-emulators.

    Anyone got any clue 'bout these problems? Wrong versions of tools or JDK? Any settings to check? Tool's launchin options to set? Firewall?

    I'm getting really frustrated with these problems, planning to get rid of Nokia's tools and changing onto using other vendors' tools.

    thnx in adv.

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    111

    Re: Several problems with NMIT 4.1

    I tried repeating your problem case with JRE 1.4.2_11, but I was still able to open older MMS messages, and create new ones, as well as push them to SDKs.

    One thing to note: in the S40 3rd Edition SDK, there is no bold vibrating notification that an MMS message arrived, all you see is the message indicator turned on.

    As far as connectivity not working to SDKs, what are all the SDKs you have installed? Sometimes a reboot to clear up old processess help.

    -Vishu

Similar Threads

  1. Several problems with NMIT 4.1
    By jtalviva in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2006-03-10, 10:59
  2. SDK + NMIT 4.1
    By versia_ep in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2006-01-14, 06:17
  3. NMIT 4.1, unable to reopen combined delivery drm files
    By phamhuu in forum Digital Rights Management & Content Downloading
    Replies: 0
    Last Post: 2005-07-14, 23:16
  4. NMIT 4.1 hanging on launch
    By acmbc68 in forum General Messaging
    Replies: 1
    Last Post: 2005-06-26, 22:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×