×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2006
    Posts
    14

    Carbide C++ Build Configs Window Corrupt

    This was working, and then it stopped - honest!

    I admit to being a complete Symbian and Carbide novice so if I have done something daft - please be kind.

    When I start Carbide C++ I now get a big red cross in the build configurations window with the error 'Unable to create view. An unexpected exception was thrown. When I click more details I see about 30-40 entries all complianing about some errors with the Java. I can post if it makes life easier.

    The first two only are:
    java.lang.NullPointerException
    at com.symbian.cdt.project.ui.SDKExplorerView.getCPPViewSelection(unknown Source).

    Not very novice friendly eh :-)

    Any and all advice to help fix welcome

    Thanks

    Paul

  2. #2
    Nokia Developer Expert
    Join Date
    Oct 2004
    Location
    Austin, TX USA
    Posts
    271

    Re: Carbide C++ Build Configs Window Corrupt

    Have you by any chance installed any software that also installed a different Java Runtime Environment? If you go to Control Panel->Add/Remove Programs, how many Java Runtime Environments do you see?

    Here's another thing to try -- if you type in a new workspace path when you start Carbide, do the errors go away?

    Regards,

    Matt P.

  3. #3
    Registered User
    Join Date
    Mar 2006
    Posts
    14

    Re: Carbide C++ Build Configs Window Corrupt

    Hi Matt

    Thanks. I have two runtimes installed (I think I have for some while now). I have V5.0 update 5 and V1.4.2_09.

    Bizarre though this may seem, so far today the workspace looks OK and the corruption has not occured (even though the machine was turned off and on last night repeatedly). Having said that, I did change my workspace and then change back so maybe that did the trick.

    Thanks for your guidance

    Paul

Similar Threads

  1. Build hangs in Carbide c++ Express
    By towebi in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 15
    Last Post: 2007-08-06, 15:10
  2. carbide: batch build options
    By juliaf in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-03-09, 15:46
  3. Problem Creating Window Using RWindow and putting More controls on it
    By er_gps212 in forum Symbian User Interface
    Replies: 0
    Last Post: 2005-10-28, 06:22
  4. About window views
    By thodime_guru in forum Symbian User Interface
    Replies: 1
    Last Post: 2004-06-17, 18:00
  5. armi build not working
    By lemody in forum Symbian
    Replies: 0
    Last Post: 2003-06-14, 15:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×