×

Discussion Board

Results 1 to 8 of 8

Thread: AT+CMGL problem

  1. #1
    Registered User
    Join Date
    Feb 2006
    Posts
    13

    AT+CMGL problem

    How can I get the message of unread messages only?

    I have tried AT+CMGL=0, but it just show "OK" without unread message shown.


    Thanks.

  2. #2
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: AT+CMGL problem

    I dont think all devices support the AT commands for reading messages, for instance my 6630 can send sms, but I cannot read or receive an incoming SMS using AT commands
    Jason Glass
    http://IChiBanComputers.Com

  3. #3
    Registered User
    Join Date
    Feb 2006
    Posts
    13

    Re: AT+CMGL problem

    I can read the unread message. But need to set AT+CPMS="ME" first. Then AT+CMGL=0 can show out the unread message.

    However, sometimes it doesnt work. Sometimes need to set AT+CPMS="SM" then AT+CMGL=0 can show the unread message.

    I dont knwo when to set "ME", when to set "SM". So unstable...
    Help..

  4. #4
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: AT+CMGL problem

    Arent "ME" and "SM" phone memory and SIM? Maybe you set it to SIM when the default storage for SMS is set to SIM(if thats possible) and vice versa. Or maybe you can only read it from SIM, if it has been manually saved to SIM by user. I am not sure, because as I stated on the 6630, I could not get change to memory locations.

    if you type AT+CMGL=? it is supposed to return storage locations? On my device, it returns ("","","")

    At least you have it partially working! Very good for you!

    Do you have documents on it, i found several online, if you want me to forward them to you.
    Jason Glass
    http://IChiBanComputers.Com

  5. #5
    Registered User
    Join Date
    Feb 2006
    Posts
    13

    Re: AT+CMGL problem

    Thank you Jason.

    I use Java to get the SMS by AT command.
    And I have used a loop to run both "ME" and "SM" so that if "ME" get nothing, it would turn to "SM".
    For document, I got AT command for nokia. what other document do you have?

    Thank you.

  6. #6
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: AT+CMGL problem

    I just found a few other documents online, relating to sending AT commands to mobile phone modems, they all basically reiterated what was in Nokias.

    I are you trying to get your app out to as many devices as possible? If yes, be carefull and fully test, because if you search the forums, people have had issues with devices not responding to the commands, or in my case(6630) responding, but incapable of allowing me access to the stored/received messages.
    Jason Glass
    http://IChiBanComputers.Com

  7. #7
    Registered User
    Join Date
    May 2009
    Posts
    2

    Re: AT+CMGL problem

    Hello,
    Can you tell me your mobile modem no. because m using E63,N70.. nokia model but m unable ream sms from that.sending message by AT command work fine on all, but read not working.
    at
    OK
    at+cpms?
    +CPMS: ,,,,,,,,

    OK
    at+cpms=?
    +CPMS: (),(),()

    OK
    AT+CPMS="SM"
    ERROR
    AT+CMGL=0
    ERROR
    So can you help me in this regards or at least you tell me your nokia mobile model no on which read command work

    Thanks & regards:
    B PRakash
    bprakash.neitl@gmail.com

  8. #8
    Registered User
    Join Date
    Dec 2008
    Posts
    2

    Re: AT+CMGL problem

    Can you please share which mobile you are using and which commands you found.
    I am trying lot to read sms on my E63 but fail, I want to know which set supports at+cpms? or any sms read command then I change to that for my project

    Quote Originally Posted by Jason Glass View Post
    I just found a few other documents online, relating to sending AT commands to mobile phone modems, they all basically reiterated what was in Nokias.

    I are you trying to get your app out to as many devices as possible? If yes, be carefull and fully test, because if you search the forums, people have had issues with devices not responding to the commands, or in my case(6630) responding, but incapable of allowing me access to the stored/received messages.

Similar Threads

  1. J2ME: Problem in Nokia Solution for a software problem
    By mte01 in forum Mobile Java Tools & SDKs
    Replies: 4
    Last Post: 2011-06-08, 05:52
  2. problem when stop playing video on 3650 and try to play again
    By niko86 in forum Mobile Java General
    Replies: 5
    Last Post: 2007-08-03, 07:40
  3. Ringing problem with Nokia N70
    By DVogdos in forum Audio
    Replies: 2
    Last Post: 2007-06-26, 20:49
  4. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  5. J2ME: Problem in Nokia Solution for a media problem
    By mte01 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-08-12, 11:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×