×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Dec 2004
    Location
    Palmas - TO - Brazil
    Posts
    8

    Help Running the OpenGL examples (3rd ed.)

    Im trying to run the OpenGL examples bundled with the S60 3rd ed. SDK. I was able to run the SimpleCube example sucessfuly in the emulator. Then I tryed to run the other examples, such EnvMapping, Billboard etc. But these other examples are just not running. When executed on the emulator, the App starts and suddenly quits, without any error message. why is that happening?

    Im using VS 2003, carbide 2.0.1 and S60 3rd Edition (not beta)

  2. #2
    Super Contributor
    Join Date
    May 2003
    Location
    Vancouver, Canada
    Posts
    985

    Re: Help Running the OpenGL examples (3rd ed.)

    Usually it is just because of the missing files (e.g. image files).
    Check bld.inf file for any needed image files. Then copy the files to your Symbian SDKs.

    Antony

  3. #3
    Regular Contributor
    Join Date
    Sep 2003
    Posts
    134

    Re: Help Running the OpenGL examples (3rd ed.)

    Same for me,
    I'm running S60 3rd ed. SDK and Carbide.c++

    SimpleLight is running, but Rain is not.. (-12 path not found...) but I check image files and they seems to be in right place.

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: Help Running the OpenGL examples (3rd ed.)

    Quote Originally Posted by ValentinK
    (-12 path not found...) but I check image files and they seems to be in right place.
    Where is that right place?

  5. #5
    Regular Contributor
    Join Date
    Dec 2005
    Posts
    442

    Re: Help Running the OpenGL examples (3rd ed.)

    Same with me when running it on the emulator, but on the real phone, it will works.
    And interesting, after some time, I will work on the emulator

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: Help Running the OpenGL examples (3rd ed.)

    Quote Originally Posted by amfat
    And interesting, after some time, I will work on the emulator
    The brute force approach is synchronizing all of epoc32\data\z\system\apps\..., epoc32\release\wins\udeb\z\system\apps\... and epoc32\release\winscw\udeb\z\system\apps... directories.

  7. #7
    Regular Contributor
    Join Date
    Sep 2003
    Posts
    134

    Re: Help Running the OpenGL examples (3rd ed.)

    I have files located at \Epoc32\release\winscw\udeb\z\private\A0000218\ folder.
    Copying them to \Epoc32\winscw\udeb\c\private\A0000218\ folder doesnt help.

    \A0000218\ folder mentioned in .sis files

Similar Threads

  1. OpenGL ES on S60 3rd Edition SDK Emulator
    By specjones in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2008-09-30, 10:22
  2. Replies: 4
    Last Post: 2008-04-16, 11:29
  3. Error running app on 3rd cell phone
    By Poyo_shiu in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2006-02-21, 09:05
  4. OpenGL ES Support in S60 3rd Edition Beta SDK
    By choefele in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2005-12-14, 06:01
  5. Problems with running SDK Java examples
    By ask_expert in forum Mobile Java General
    Replies: 1
    Last Post: 2002-05-08, 16:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×