×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Mar 2006
    Posts
    7

    problem with sending message over network

    ssc = (ServerSocketConnection) Connector.open("socket://:5000");

    sc = (SocketConnection) Connector.open("socket://localhost:5000");

    my app works over the network in the emulator, but wont work on real devices, or do i just need to pair somehow with the device before i start.
    are the above lines okay is it meant to be localhost that's what they use in the socket part of the network demo that comes with the wireless toolkit, anyone have any ideas why that app doesnt seem to work for me on the real devices.
    i know for bluetooth you have to pair with the device before running the application do you have to do something like this

  2. #2
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: problem with sending message over network

    Hi podge_boy,

    I think it's important to consider differences in client and server connection modes, make sure you understand them.

    Besides, localhost is your local, loopback address (127.0.0.1) and the demo uses it to demonstrate how to access a local server.

    If you want to send a message just use a SocketConnection and provide your server's local address and port. Also make sure your device's access point is configured properly.

    Nedless to mention that your server side must be available, known.

    Note that if your server is another MIDlet using ServerSocketConnection your operator must make its IP address available to you, sometimes that's not possible.

    The operator not supporting socket connections may be an issue as well.

    Hope this helps!!!

    BR

Similar Threads

  1. Problem sending SMS using Nokia 6210 and SDK 2.1
    By tarnaigy in forum PC Suite API and PC Connectivity SDK
    Replies: 4
    Last Post: 2006-02-01, 22:01
  2. problem to send a service loading message push for 8310
    By alinesimon in forum General Messaging
    Replies: 1
    Last Post: 2002-05-06, 12:39
  3. Problem to send a service loading push message for 8310
    By alinesimon in forum General Messaging
    Replies: 1
    Last Post: 2002-05-06, 11:19
  4. Problem to send a service loadinfd push message for 8310
    By alinesimon in forum Smart Messaging
    Replies: 1
    Last Post: 2002-05-03, 10:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×