×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jan 2006
    Posts
    7

    Thumbs down N70 BUG: drawrgb() after translate()

    hi, i found a bug on my nokia N70

    Code:
    g.translate(50,50);
    //g.drawImage(image, 0, 0, TOP_LEFT_ANCHOR);
    g.drawRGB(rgbimage, 0, width, 0, 0, width, height, false);
    g.translate(-50,-50);
    "rgbimage" is an array of int, filled with image.getRGB().
    This code should paint the image at (50, 50).
    in fact this code works ok on both sun and nokia emulators, but when i run it on my N70 the image is rendered at (0, 0). Using drawImage the image is rendered correctly at (50, 50).

    Can someone else try this code on other s60 mobiles?

    this is a problem for me, i have to use drawRGB() after the translation of the Graphics' origin, in an important j2me project.

    thank you.

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    24

    Re: N70 BUG: drawrgb() after translate()

    Hi,
    I have the same problem too on the same model.
    P.D.

  3. #3
    Registered User
    Join Date
    Jan 2006
    Posts
    7

    Re: N70 BUG: drawrgb() after translate()

    i wrote a little example, you can find it here:

    http://rapidshare.de/files/16779438/NOKIABUG.rar.html

Similar Threads

  1. N70 Reset bug
    By sebboB in forum General Development Questions
    Replies: 2
    Last Post: 2005-12-28, 23:09
  2. N70 'contacts' bug problem
    By benbytes in forum General Development Questions
    Replies: 4
    Last Post: 2005-11-09, 20:41
  3. A bug: setColor with offscreen graphics - PLEASE, REPLY THIS TIME
    By palmcrust in forum Mobile Java General
    Replies: 11
    Last Post: 2003-12-04, 12:43
  4. Firmware bug or code bug displaying list on 3650
    By blackjack75 in forum Mobile Java General
    Replies: 2
    Last Post: 2003-09-24, 19:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •