×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Feb 2006
    Posts
    13

    Nokia 6630 firmware secuirty error

    Hi,

    I have an app that has been signed by Verisign certificate using WTK2.2 for a Nokia 6630.
    It installs fine on firmware version 03.45.113 and runs fine. On firmware version 05.03.08 it gives the "Installation security error: Unable to install" error. I have made sure that Install Applications is set to "ON" for the phone as well for all the versigin certificates on the phone.

    I will try signing the midlet with the new version of WTK but are there any ideas why this could be the case.

    In my JAD I have

    MIDlet-Certificate-1-1:
    MIDlet-Certificate-1-2:
    MIDlet-Jar-RSA-SHA1:

    entries. Any help from Nokia would be nice

    Thanks.
    Last edited by RastaS2K; 2006-04-05 at 02:04.

  2. #2
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Nokia 6630 firmware secuirty error

    If the same jar and jad files (without any changes) worked with the earlier firmware, it looks like the new firmware does not contain the right certificate. I happen to have the same (old) firmware on my phone. There are three class 1,2,3 certificates, and on class 4 certificate from Verisign. Before I write here fingerprints of all the certificates so you can compare, can you tell what was the class of the certificate you signed your app with?

    Hartti

  3. #3
    Registered User
    Join Date
    Feb 2006
    Posts
    13

    Re: Nokia 6630 firmware secuirty error

    Thanks Hartti,

    It was signed with Class 3.

  4. #4
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: Nokia 6630 firmware secuirty error

    i have a 6630 from tmobile, with old firmware, if you kids need any help comparing

    generally dont have issues installing signed apps on it
    Jason Glass
    http://IChiBanComputers.Com

  5. #5
    Registered User
    Join Date
    Feb 2006
    Posts
    13

    Re: Nokia 6630 firmware secuirty error

    Hi Jason,

    What firmware are you running on your mobile -> *#0000#

    Thanks

  6. #6
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: Nokia 6630 firmware secuirty error

    3.45.110
    02-12-04
    RM-1
    Jason Glass
    http://IChiBanComputers.Com

Similar Threads

  1. Replies: 2
    Last Post: 2005-09-05, 13:51
  2. Sending message between Nokia 6260 and Nokia 6630 problem
    By fgozman in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2005-03-18, 11:10
  3. Nokia 6630
    By dharma88 in forum General Development Questions
    Replies: 1
    Last Post: 2005-02-20, 10:36
  4. Dialogs within Symbian 6.0 based SDK
    By georgica1979 in forum Symbian User Interface
    Replies: 14
    Last Post: 2003-04-07, 15:29
  5. Series 60Series 60 MIDP Concept SDK Beta 0.2 Linux bug?
    By kauppi in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2003-04-07, 09:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×