×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Apr 2006
    Posts
    1

    My BuilderX (with S60 SDK 2.1.NET MS version) cannot build ARMI UREL

    Here is what my messages window shows in BuilderX when i try to compile an ARMI UREL. This is a blank application i created:

    bldmake -v bldfiles
    abld -v makefile ARMI
    perl -S makmake.pl -D \SYMBIANEX\05APRIL\GROUP\APRIL8 ARMI
    abld -v reallyclean ARMI UREL
    Clean finished
    bldmake -v bldfiles
    abld -v export
    abld -v makefile ARMI
    perl -S makmake.pl -D \SYMBIANEX\05APRIL\GROUP\APRIL8 ARMI
    abld -v resource ARMI UREL
    perl -S epocrc.pl -I "..\SRC" -I "..\INC" -I- -I "..\..\..\SYMBIAN\7.0S\SERIES60_V21\EPOC32\INCLUDE" -I "..\..\..\SYMBIAN\7.0S\SERIES60_V21\EPOC32\INCLUDE\BORLAND" -DLANGUAGE_01 -u "\SYMBIANEX\05APRIL\SRC\APRIL8.RSS" -o\Symbian\7.0s\Series60_v21\EPOC32\DATA\Z\SYSTEM\APPS\APRIL8\APRIL8.R01 -h"\Symbian\7.0s\Series60_v21\EPOC32\BUILD\SYMBIANEX\05APRIL\GROUP\APRIL8\ARMI\APRIL8.rsg" -t"\Symbian\7.0s\Series60_v21\EPOC32\BUILD\SYMBIANEX\05APRIL\GROUP\APRIL8\ARMI" -l"Z\SYSTEM\APPS\APRIL8:\SYMBIANEX\05APRIL\GROUP"
    perl -S ecopyfile.pl "\Symbian\7.0s\Series60_v21\EPOC32\BUILD\SYMBIANEX\05APRIL\GROUP\APRIL8\ARMI\APRIL8.rsg" "\Symbian\7.0s\Series60_v21\EPOC32\INCLUDE\APRIL8.RSG"
    perl -S emkdir.pl \Symbian\7.0s\Series60_v21\EPOC32\BUILD\SYMBIANEX\05APRIL\GROUP\APRIL8\ARMI\UREL
    abld -v library ARMI
    Compile finished
    abld -v target ARMI UREL
    "e32std.h": parse error before `typedef' at line 4076
    "e32std.h": parse error before `(' at line 4084
    "e32std.h": syntax error before `;' at line 4086
    "e32std.h": parse error before `)' at line 4126
    "e32std.inl": parse error before `;' at line 3131
    "e32std.inl": parse error before `(' at line 3133
    "e32std.inl": syntax error before `(' at line 3133
    "e32std.inl": syntax error before `{' at line 3139
    "e32std.inl": syntax error before `{' at line 3142
    "e32std.inl": syntax error before `:' at line 3147
    "e32std.inl": syntax error before `:' at line 3151
    "e32std.inl": syntax error before `:' at line 3155
    "e32std.inl": syntax error before `{' at line 3159
    "e32std.inl": syntax error before `{' at line 3162
    "e32std.inl": syntax error before `{' at line 3165
    "e32std.inl": syntax error before `{' at line 3168
    "e32std.inl": syntax error before `{' at line 3171
    "e32std.inl": syntax error before `{' at line 3174
    "e32std.inl": syntax error before `{' at line 3177
    "e32std.inl": syntax error before `{' at line 3180
    "e32std.inl": syntax error before `{' at line 3183
    "e32std.inl": syntax error before `{' at line 3186
    "e32std.inl": syntax error before `{' at line 3189
    "e32std.inl": syntax error before `{' at line 3192
    "e32std.inl": syntax error before `{' at line 3195
    "e32std.inl": syntax error before `{' at line 3198
    "e32std.inl": syntax error before `{' at line 3201
    "e32std.inl": syntax error before `{' at line 3204
    "e32std.inl": syntax error before `{' at line 3207
    "e32std.inl": syntax error before `{' at line 3210
    "e32std.inl": syntax error before `{' at line 3213
    "e32std.inl": syntax error before `{' at line 3216
    "e32std.inl": syntax error before `{' at line 3219
    "e32std.inl": syntax error before `{' at line 3222
    "e32std.inl": syntax error before `{' at line 3225
    "e32std.inl": syntax error before `{' at line 3228
    "e32std.inl": syntax error before `{' at line 3231
    "e32std.inl": syntax error before `{' at line 3234
    "e32std.inl": syntax error before `{' at line 3237
    ...
    "e32base.h": parse error before `<' at line 421
    "e32base.h": confused by earlier errors, bailing out at line 503

    gcc -s -fomit-frame-pointer -O -march=armv4t -mthumb-interwork -pipe -c -nostdinc -Wall -Wno-ctor-dtor-privacy -Wno-unknown-pragmas -DNDEBUG -D_UNICODE -D__SYMBIAN32__ -D__GCC32__ -D__EPOC32__ -D__MARM__ -D__MARM_ARMI__ -D__DLL__ -I "..\SRC" -I "..\INC" -I "..\..\..\SYMBIAN\7.0S\SERIES60_V21\EPOC32\INCLUDE" -I "..\..\..\SYMBIAN\7.0S\SERIES60_V21\EPOC32\INCLUDE\BORLAND" -o ..\..\..\SYMBIAN\7.0S\SERIES60_V21\EPOC32\BUILD\SYMBIANEX\05APRIL\GROUP\APRIL8\ARMI\UREL\APRIL8APP.o "..\SRC\April8app.cpp"
    abld -v final ARMI UREL
    abld -c build ARMI UREL
    MISSING: \Symbian\7.0s\Series60_v21\EPOC32\RELEASE\ARMI\UREL\APRIL8.APP
    MISSING: \Symbian\7.0s\Series60_v21\EPOC32\RELEASE\ARMI\UREL\APRIL8.APP.MAP

    abld -w build ARMI UREL
    makesis -v -dC:\Symbian\7.0s\Series60_v21\epoc32\release\ARMI\UREL _tmp53976.pkg April8_ARMI_UREL.sis
    "_tmp53976.pkg": processing languages at line 1
    "_tmp53976.pkg": processing header at line 3
    "_tmp53976.pkg": processing dependency at line 4
    "_tmp53976.pkg": processing file at line 6
    "_tmp53976.pkg": error: file not found at line 6
    External process exited with error code : 1
    Build finished


    I get this always,if i import an example and also when i create a new application.THUMB Urel is the same. Wins urel works OK,there are a few warnings only but no errors.

    I installed the following tools/programs for the sake of Symbian programming:(I'm not sure if all of them are necessary, probably not):
    BuilderX 1.5 free version
    Series 60 SDK version 2.1 .NET (Microsoft version)
    Activeperl 5.6.1
    debugging tool for windows
    MSXML 4.0 SP2
    .NET Farmework soft dev kit ver 1.1
    .NET Framework SDK 1.1
    .NET Framework 1.1 Reditributable package
    Windows Platform SDK SP1
    Visual C++ Toolit 2003
    Visual J# .NET Redistributable Package 1.1
    dumpbin.exe and link.exe(from http://pf128.krakow.sdi.tpnet.pl/symbdev/)


    The MMP file is as follows:
    TARGET April8.app
    TARGETTYPE app
    UID 0x100039CE 0x1000009
    TARGETPATH \system\apps\April8

    LANG 01

    SOURCEPATH ..\src
    SOURCE April8main.cpp
    SOURCE April8app.cpp
    SOURCE April8document.cpp
    SOURCE April8appui.cpp
    SOURCE April8view.cpp
    SOURCE April8container.cpp

    RESOURCE April8.rss

    USERINCLUDE ..\inc

    SYSTEMINCLUDE \epoc32\include
    SYSTEMINCLUDE \epoc32\include\borland

    LIBRARY euser.lib
    LIBRARY apparc.lib
    LIBRARY cone.lib
    LIBRARY eikcore.lib
    LIBRARY avkon.lib
    LIBRARY egul.lib
    LIBRARY eikcoctl.lib
    LIBRARY bafl.lib
    LIBRARY eikctl.lib
    LIBRARY fbscli.lib
    LIBRARY etext.lib
    LIBRARY form.lib
    LIBRARY gdi.lib
    LIBRARY insock.lib
    LIBRARY aknnotify.lib
    Last edited by danielvidonyi@hotmail.com; 2006-04-08 at 23:03.

  2. #2
    Registered User
    Join Date
    Aug 2005
    Posts
    9

    Re: My BuilderX (with S60 SDK 2.1.NET MS version) cannot build ARMI UREL

    Hi, I am facing the same problem.
    I tried codewarrior with the same code and it worked fine, so i dont think the problem is in the code but maybe in the configuration of some tool. unfortunately no one seems to be able to help us. strange. does cbx really work?

Similar Threads

  1. Latest Carbide.vs and problems with ARMI build
    By mhakkara in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2006-04-05, 10:17
  2. nokia 7210 modem via IR doesn't work !
    By oussamaaiadi in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2003-03-06, 10:46
  3. Http connection problem in 6310i
    By teahola in forum Mobile Java General
    Replies: 1
    Last Post: 2002-10-03, 18:46
  4. using abld build armi urel
    By srinath_ramaraju in forum Symbian
    Replies: 2
    Last Post: 2002-08-14, 03:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×