×

Discussion Board

Results 1 to 2 of 2

Hybrid View

  1. #1
    Super Contributor
    Join Date
    Mar 2003
    Posts
    2,426

    WTAI and Nokia 6210....

    We are testing wireless applications with Oracle ASW release 2.0 beta 4 and a Nokia 6210 WAP phone.

    I have the following question:

    I'm testing a phone list application using the following code:

    <?xml version = "1.0" encoding = "UTF-8" standalone="yes" ?>
    <!DOCTYPE SimpleResult PUBLIC "-//ORACLE//DTD SimpleResult 1.1//EN"
    " " target="_new">http://xmlns.oracle.com/ias/dtds/SimpleResult_1_1_0.dtd"> <SimpleResult>
    <SimpleContainer>
    <SimpleText>
    <SimpleTextItem><SimpleEm>Oracle</SimpleEm> Support </SimpleTextItem>
    <SimpleTextItem>Phone Book<SimpleBreak/>
    <SimpleHref static_target="callto:+14155551212">Bob</SimpleHref>
    <SimpleHref static_target="callto:+16505551212">Chris</SimpleHref>
    <SimpleHref static_target="callto:+14085551212">Dina</SimpleHref>
    <SimpleHref static_target="callto:+17075551212">Jere</SimpleHref>
    </SimpleTextItem>
    </SimpleText>
    </SimpleContainer>
    </SimpleResult>

    After debugging the telephone list application using the WML11 stylesheet the following WTAI code is generated:

    <?xml version="1.0" encoding="UTF-8"?> <!DOCTYPE wml PUBLIC "-//WAPFORUM//DTD WML 1.1//EN" " " target="_new">http://www.wapforum.org/DTD/wml_1.1.xml"> <wml>
    <head>
    <meta http-equiv="Cache-Control" content="max-age=10" forua="true"/>
    </head>
    <template/>
    <card id="_1"><p><em>Oracle</em> Support
    </p>
    <p>Phone Book<br/>
    <anchor><go href="wtai://wp/mc;+14155551212"/>Bob</anchor>
    <anchor><go href="wtai://wp/mc;+16505551212"/>Chris</anchor>
    <anchor><go href="wtai://wp/mc;+14085551212"/>Dina</anchor>
    <anchor><go href="wtai://wp/mc;+17075551212"/>Jere</anchor>
    </p>
    </card>
    </wml>

    Testing this with Nokia6210 (Nokia6210/1.0 (05.27)) phone, I can see the telephone list and am able to select a name. The problem is that the phone won't call the number. On the Nokia forum I've found out that the latest (WAP) devices (with the latest firmware versions) should support the WTAI code above. Is this a problem related to the model of my phone? Any other suggestions of things I could try?

    Thanks in advance.

    Thomas

    Posted by Thomas Wesseling, thomas.wesseling@ucc.nl

  2. #2
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    196

    RE: WTAI and Nokia 6210....

    Hi,

    the 6210 does not support WTA, instead you can use feature Use Number. It is found under the options key, but the phone number needs to be in the body of the card. eg.

    <anchor><go href="wtai://wp/mc;+14155551212"/>Bob +14155551212</anchor>

    BR,
    Pete

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •