×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Regular Contributor
    Join Date
    Sep 2003
    Posts
    134

    Unhappy Carbide.C++ error. The input line is too long.

    Hello,
    I have an error compiling application.

    The input line is too long.
    make: *** [S:/9.1/S60_3rd/epoc32/release/WINSCW/UDEB/MyApp.exe] Error 255

    Any fixes? or I should make my application class names shorter? Is it the only solution for this?

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide.C++ error. The input line is too long.

    This is a known issue which will be fixed in a future product release. Shortening names etc will obviously help.

  3. #3
    Regular Contributor
    Join Date
    Sep 2003
    Posts
    134

    Re: Carbide.C++ error. The input line is too long.

    Unfortunately, shorten of file names is not the solution. I have >90 object files and this is not a full project ported. So even 2 letters per object will be not enough ... Very disappointed...

    I found in post http://discussion.forum.nokia.com/fo...=line+long+255

    The workaround is to build from the command-line and use the Symbian Executable Importer in Carbide to create a project for you. From there you can create a Launch Config and debug your application/sources. The build issue is a known core eclipse issue and we're looking to address it in the next release.

    Could you give a bit more information about "Symbian Executable Importer" What is it? Where I could find it and any information about usage.

  4. #4
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Carbide.C++ error. The input line is too long.

    Well, you seem not to be in the intended Express target customer group; new developers just learning Symbian or doing small personal projects rarely need to import projects that size. If you are doing full-scale commercial development you can use CW now and take Carbide.c++ Developer or Pro into use once they are released, these are the products intended for full scale commercial development.

    For the Exe import, see Carbide.c++ Help, section "Importing Symbian Executables".

  5. #5
    Regular Contributor
    Join Date
    Sep 2003
    Posts
    134

    Re: Carbide.C++ error. The input line is too long.

    CodeWarrior is an awful IDE for work and debugging, I used to work with Visual Studio 6.0 which is almost perfect. And Carbide.C++ Express never mentioned in this case as "For example compiling" only. I would like to use Carbide as my main development IDE in future and I dont need on-targed debugging (from Carbide.C++ Developer package).

  6. #6
    Registered User
    Join Date
    Apr 2006
    Posts
    18

    Re: Carbide.C++ error. The input line is too long.


  7. #7
    Regular Contributor
    Join Date
    Sep 2003
    Posts
    134

    Re: Carbide.C++ error. The input line is too long.

    This helps if input line for compiling sinlge object is too long. But it still an error for project cleanup and biggest problem is all object linking.

  8. #8
    Nokia Developer Expert
    Join Date
    Dec 2004
    Location
    Austin, TX
    Posts
    399

    Re: Carbide.C++ error. The input line is too long.

    I just noticed this problem occurs on (some?) Windows 2000 machines when the command-line limit is > 2047. I could have sworn when I used Win2K previously it was 32K. This problem doesn't appear to occur on WinXP where I think the command limit is ~32K. This also happens more frequently on GCCE builds becuase 1) The -search option doesn't work in the linker so all the libraries have to be specified by full path and 2) The @options.txt paramater doesn't work. This is based on what I know about the Q1C2005 release. There is a 2006 release of GCCE at codesourcery.net, but I haven't tried it out yet (http://www.codesourcery.com/gnu_toolchains/arm/)

    Tim

  9. #9
    Registered User
    Join Date
    Jul 2005
    Posts
    14

    Re: Carbide.C++ error. The input line is too long.

    hi,

    the 2006 releases are built with gcc 4.x, which doesn't work with the (... insert random curse word here ...) symbian headers.

    i currently use the 2005q3-2 release, but there are three issues to take into account:

    1) The installer broke my environment variables. The fix noted in http://discussion.forum.nokia.com/fo...ad.php?t=49418 regarding the replacement of %SystemRoot% with it's value helped. The symptom is bldmake complaining about the EPOCROOT variable not being capitalised.

    2) You'll need to adopt the system include path in EPOCROOT/Epoc32/tools/compilation_config/gcce.mk. Just search for 3.4.3 and change it to 3.4.4, that's it. Oh, and if you use VI or another compiler that creates backup files (in this case gcce.mk~), remove it before continuing. The resulting error would be ugly and extremely hard to track down. took me a few hours...

    3) change the file cl_bpabi.pm located in EPOCROOT/Epoc32/tools, line around 225, to also point to 3.4.4 instead of 3.4.3 (so bldmake tells your new shiny gcc 3.4.4 where to find it's libgcc.a)

    that's it. it fixes the path problems for me.

  10. #10
    Registered User
    Join Date
    Apr 2004
    Posts
    9

    Re: Carbide.C++ error. The input line is too long.

    I did the changes as above but did not work for me. Same error persists.

    Any other help?

  11. #11
    Registered User
    Join Date
    Apr 2004
    Posts
    9

    Re: Carbide.C++ error. The input line is too long.

    I compiled the same application on XP machine and went fine.
    It looks that it is OS limitation for those using W2K.

    My advice, use xp. If persists, use recommendations above.

  12. #12
    Registered User
    Join Date
    Jul 2005
    Posts
    14

    Re: Carbide.C++ error. The input line is too long.

    i use winxp and had the problem, i don't think it's relevant

  13. #13
    Registered User
    Join Date
    Apr 2004
    Posts
    9

    Re: Carbide.C++ error. The input line is too long.

    My application on W2K had this problem. I transferred the application to XP and compiled OK without any change!

    Additional recommendations (if does not solve this problem - again on XP)

    1)
    - subst library path from cmd prompt
    subst x: C:\Symbian\9.1\S60_3rd_MR\Epoc32\release
    - on carbide, go to project properties - environment and add this entry
    EPOC32_RELEASE_ROOT --> x:\

    this will reduce command line considerably "if you're using many libraries".

    2) to go further, do a substitute to EPOCROOT variable as above (y

  14. #14
    Regular Contributor
    Join Date
    Sep 2003
    Posts
    134

    Re: Carbide.C++ error. The input line is too long.

    Is this bug fixed since Nokia introduce new Carbide.C++ versions???

  15. #15
    Registered User
    Join Date
    Apr 2004
    Posts
    9

    Re: Carbide.C++ error. The input line is too long.

    I do not beleive V1.1 solves this issue since it is related to W2K OS and not compiler.
    The problem is that W2K does not support command line >2K. In XP, it supports up to 8K. So, if you have TOO MANY files to link, command line will exceed 2K in W2K and problem arises.

    One suggested earlier to use make file for too many files on W2K.

    Good luck.

Similar Threads

  1. problem with Code Warrior 5.2
    By mayankkedia in forum Symbian
    Replies: 4
    Last Post: 2006-06-22, 08:26
  2. My BuilderX (with S60 SDK 2.1.NET MS version) cannot build ARMI UREL
    By danielvidonyi@hotmail.com in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-05-04, 21:30
  3. Carbide.c++ Express don't want build HelloWorld
    By azarov-it in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 7
    Last Post: 2006-04-09, 11:00
  4. 关于Float的问题,急死了,各位帮忙一下,谢谢!
    By show_up in forum [Archived] Other Programming Discussion 关于其他编程技术的讨论
    Replies: 4
    Last Post: 2004-08-17, 08:57
  5. PC Connectity with VB6
    By mkintanar in forum PC Suite API and PC Connectivity SDK
    Replies: 5
    Last Post: 2003-09-24, 04:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×