×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    Feb 2004
    Posts
    99

    Question App dosent launch if installed on Memory card.

    Hi All,

    My Application has a view and a Container .. and the container consist of lot of other controls. If I install my application on a Phone Memory ( c: ) everything works fine. I dont have a single hardcoded value for paths ( I am using \\system\\apps\xyz.png ) for giving the paths. Now, if I install the application on a Memory card ( E: ) the app dosent starts at all, I debuged the code. It reaches the SetDefaultViewL(*iMyView); but the DoActivateL() of my view is never getting called. Why such a difference if I install it on C: works fine but on E: dosent works.

    Can anyone please tell me the problem?

    thanks in Advance.

    ..
    Kiran Puranik

  2. #2
    Regular Contributor
    Join Date
    Oct 2004
    Location
    india
    Posts
    306

    Re: App dosent launch if installed on Memory card.

    hi,

    """"""""""""""I dont have a single hardcoded value for paths ( I am using \\system\\apps\xyz.png ) for giving the paths. """""""""

    use completewithapppath(_L("\\system\\apps\xyz.png"));


    regards
    N

  3. #3
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    79

    Re: App dosent launch if installed on Memory card.

    First of all, i think, there should be double slash in "...apps\\xyz.png", Try to exlude picture loading procedure. And try to use ApplicationDriveAndPath() function instead of such name (You can find this function in SDK examples). With missing some componentes in the path, the file session adds the default.

  4. #4
    Regular Contributor
    Join Date
    Mar 2005
    Location
    Bangalore,India
    Posts
    306

    Re: App dosent launch if installed on Memory card.

    check pkg file too
    incase if u have written "c:" instead of !

Similar Threads

  1. Storing my data on memory card on Series 40 phones
    By Sammybar in forum Mobile Java General
    Replies: 1
    Last Post: 2005-12-28, 17:40
  2. memory card
    By mary_adi in forum General Development Questions
    Replies: 0
    Last Post: 2004-09-01, 08:15
  3. 6600 memory card
    By puttnamb1 in forum General Development Questions
    Replies: 0
    Last Post: 2004-06-30, 16:31
  4. Memory Card Formatting
    By Nokia_Archive in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2002-11-27, 10:24
  5. can not successfully link any sample using .NET
    By lobotomat in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2002-08-20, 00:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •