×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Apr 2006
    Posts
    3

    Character ê â not displaying on N3230 using UTF-8

    Hello All,

    Myself Bineet, i m testing some characters ê â using simple TEXT mode using own sms gateway (encoded UTF-8) in java but both above characters are not coming properly on N3230. otherwise some other chars. like é à è ù are coming properly on N3230. when i test it display u for ê and q for â. please help me how can i encode in java to display properly.

    Thanks

    Bineet

  2. #2
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,105
    Are you doing Java MIDP or is this on a desktop computer (J2SE)? I would guess your SMS gateway is buggy and does not detect to switch to UCS-2 automatically when using those characters.

  3. #3
    Registered User
    Join Date
    Apr 2006
    Posts
    3

    Re: Character ê â not displaying on N3230 using UTF-8

    Thanks for your reply, i have some developed pages in jsp using jboss for sending sms to our sms gateway which implemented standard protocol smpp and take care simple text, ucs, etc. and multilingual support everything works fine. hexa value for each é à ê è ù â works very fine here hexa (00E9,00E0,00EA,00E8,00F9,00E2) but here i m sending in simple TEXT mode all these chars. only ê and â chars not display properly it converts into u and q respectively. i m using java.net.URLEncoder.encode(String msg, String enctype) which is UTF-8. i know it is not handset problem while N3230 support these two chars. tested on hexa mode but help me in simple TEXT mode. is there any other enc-type need to use?

    Thanks

    Bineet

  4. #4
    Nokia Developer Champion
    Join Date
    Mar 2003
    Posts
    4,105
    Have you read and understand my reply? Does your SMS Gateway send an Unicode (UCS-2) SMS?

  5. #5
    Registered User
    Join Date
    Apr 2006
    Posts
    3

    Re: Character ê â not displaying on N3230 using UTF-8

    It was in my mind but i wanted to clear some other things but thanks for your reply. i have forwarded your comment to my next team.

Similar Threads

  1. ERROR RCmake.exe AND rcomp.exe
    By jifik in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2005-10-31, 12:24
  2. Errors compilling and debugging Helloworld
    By doberlet in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2004-03-04, 18:08
  3. Codewarrior import .mmp error
    By serenade in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2004-02-21, 20:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •