I am trying to use the j2me but not getting the Jbuilder 5 personal edition so i tried using Jbuilder 7.0 and downloaded the JBuilder 7 Mobile kit with it but then i am using the nokia developer's suite for J2ME which was meant for jBuilder 5 . Will the set up work.Is it possible to use Visual Basic instead of all this and i tried using the gfsms but could not download it .Kindly suggest.