×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Apr 2006
    Posts
    14

    package does not exist

    hi
    i found some code source that i want to compile under j2me for my project, in the code source i can read the ligne import com.barcode.*; but an error is returned when i build : package com.barcode does not exist , obviously , i must add the necessary classes provided with the source code to my application .
    how can i do it and where shall i put them.
    thanks for help

  2. #2
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: package does not exist

    Hi chiamnov,

    You'll need the JAR file that contains the classes/interfaces in this com.barcode.* namespace. Just add it to your classpath...

  3. #3
    Registered User
    Join Date
    Nov 2005
    Posts
    33

    Re: package does not exist

    hi


    For me too "package org.w3c.dom does not exist" is the error thrown.
    From where should i download the .jar or .zip file for this package.
    Im using Netbeans5.0 . So how to link that .jar file with netbeans.

    Otherwise how to set the classpath.

    Plz suggest me...
    Thanks in advance

    yafy

  4. #4
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: package does not exist

    yafy, in netbeans, you can right click the project, select properties, then select "Libs and resources" under "build"

    click add jar/zip

    the browse to the jar files location
    Jason Glass
    http://IChiBanComputers.Com

  5. #5
    Regular Contributor
    Join Date
    Jul 2005
    Location
    Omaha, US
    Posts
    129

    Re: package does not exist

    If you are not using netbeans, put the jar file into the lib of your jme application (In case if WTK).

  6. #6
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: package does not exist

    cool prashant thanks, i knew the netbeans, but not the wtk
    Jason Glass
    http://IChiBanComputers.Com

  7. #7
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: package does not exist

    Hi yafi,

    In addition to what Jason and prashant332 informed, the org.w3c.dom package is available in JSE (1.4.2_X, 1.5.0_X). See:

    Package org.w3c.dom
    Provides the interfaces for the Document Object Model (DOM) which is a component API of the Java API for XML Processing.

    BR,

    Juarez Junior

  8. #8
    Registered User
    Join Date
    Nov 2005
    Posts
    33

    Re: package does not exist

    Actually i have JSE1.4.2_11 . But still im getting "org.w3c does not exist".
    In Netbeans ,project,properties , libs and resourses i have added kxml.jar , jdom.jar. also.

    Actually what else i have to do . plz suggest what im missing....

    thanks
    yafy.

  9. #9
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: package does not exist

    Hi yafy,

    Which IDE are you using then? Just copy these jars from NetBeans and include them in your classpath. I think it's unnecessary when using JSE and cannot see the reasons why this package is not getting resolved, though...

    BR,

    Juarez Jr

  10. #10
    Registered User
    Join Date
    Nov 2005
    Posts
    33

    Re: package does not exist

    how to include in classpath ...
    what are the steps for that.plz suggest...

    yafy

  11. #11
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: package does not exist

    Hi yafy,

    It depends on the IDE you're using. Probably is enough to right-click your Project and choose "Properties". Look for libraries or classpath or dependencies.

    Just a tip, if you do not know what the classpath is and how to set it you're in trouble. Sip some Java

    BR,

    Juarez Jr

Similar Threads

  1. WMA package
    By k_salil in forum Mobile Java General
    Replies: 1
    Last Post: 2004-06-07, 09:50
  2. The requested protocol does not exist http://www.yahoo.com
    By polrtex in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2004-04-25, 06:51
  3. Help! package "com.nokia" doesn't exist
    By mwiezik in forum Mobile Java Tools & SDKs
    Replies: 4
    Last Post: 2004-03-11, 04:32
  4. Creting Application package fileNotFound error
    By pid0101 in forum Mobile Java General
    Replies: 0
    Last Post: 2004-01-19, 19:55
  5. package com.nokia.mid.ui does not exist
    By kapapra in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2003-10-14, 04:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×