×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jan 2006
    Posts
    8

    Unhappy Problem with Forms. Please help me!!

    Hello to everybody!
    I have a very strange problem:
    I am now testing my application to real (S40 2nd edition) phones (not emulators). My application displays data in forms. The form scrolls up and down to display the contents. However in some forms when you scroll down you cannot scroll up again! And this happens only in Nokia 7260 and 7270 phones and in specific forms... I rebooted the phone but the same thing happened again and for the same forms... This strange behavior appears in different forms for 7260 phone and in other forms for 7270.

    I tested the application in 8800, 6103 and 6280 and everything is OK...

    I must mention that the content displayed in these forms is not different or bigger in size than in the other forms which are displayed correctly.

    Could that be a memory problem?

    Please help me! Any suggestion is valuable for me!
    Thank you,

    Annie

  2. #2
    Registered User
    Join Date
    Jan 2006
    Posts
    8

    Re: Problem with Forms. Please help me!!

    It's me again.
    I see that no one gave any idea... Is there any expert from Nokia who could give any suggestion?

    Please...! I would appreciate any idea or suggestion!

    Thanks,
    Annie

  3. #3
    Registered User
    Join Date
    Jan 2006
    Posts
    8

    Unhappy Re: Problem with Forms. Please help me!!

    Since nobody seems to know about this issue, I am still trying to solve it. If I find any solution, I will let you know.

    I have a number of UTF-8 text files which my application reads. I read these texts into strings (UTF-8). The contents of these strings are displayed in forms. Everything works perfect with all S40 emulators (and the WTK) and with the real phones mentioned in my 1st post.

    The problem occurs in 7260 and 7270 phones... They are both S40 2nd edition.

    I created the text files again, I tried to find some strange charactes in them (using UltraEdit program), I tried to put an '\n' character at the end of the form hoping that it could "help" the form scroll. Nothing....

    The "problematic" forms are always the same and different in each phone... They scroll down but not up! If I scroll down to almost the end of the form - but not at the end - then it's OK. I can scroll up again.

    Pleaseeeeeee! Does anybody have an idea?

    Thanks,
    Annie

  4. #4
    Registered User
    Join Date
    Jan 2006
    Posts
    8

    Thumbs up Re: Problem with Forms. Please help me!!

    I found what the problem was and I post it for anyone interested:
    It was a memory problem. I entered the heap size of 7270 handset to the emulator and the problem with the scrolling of the forms appeared again.

    Hello to everybody.

Similar Threads

  1. J2ME: Problem in Nokia Solution for a software problem
    By mte01 in forum Mobile Java Tools & SDKs
    Replies: 4
    Last Post: 2011-06-08, 05:52
  2. problem when stop playing video on 3650 and try to play again
    By niko86 in forum Mobile Java General
    Replies: 5
    Last Post: 2007-08-03, 07:40
  3. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  4. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  5. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×