×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Dec 2005
    Posts
    59

    Java 1.3.1 Required

    There are tools in the Symbian 7.0s SDK that require the Java 1.3.1 runtime environment. I have installed Java Version 1.5.0 (build 1.5.0_06-b05), but the Symbian tools still complain that the 1.3.1 Runtime Environment is needed. Do I really need to downgrade my Java to this old version in order for the Symbian tools to run? (The complaining tools are the Series 60 tools AIF Builder, CS Help Compiler, and Sisar).

    Robert Scott
    Ypsilanti, Michigan

  2. #2
    Regular Contributor
    Join Date
    Dec 2005
    Posts
    59

    Re: Java 1.3.1 Required

    After a brief Google search, I found the answer to my question. Find the registry key:

    HKLM\Software\JavaSoft\Java Runtime Environment\x.y.z

    where x.y.z is the version numbering of a more recent Java runtime environment. Export that entire key, use Notepad to edit the .reg file to change the x.y.z to 1.3.1. Then re-import that branch of the registry. This will form a key of the form that the Symbian apps are looking for.

    Robert Scott
    Ypsilanti, Michigan

Similar Threads

  1. Replies: 2
    Last Post: 2004-09-27, 09:58
  2. Series 60 SDK 2.0 and Java 1.3.1
    By akumria in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2004-05-06, 21:52
  3. Replies: 0
    Last Post: 2004-02-04, 16:14
  4. How develop Java games on mobile phones?
    By ericzutter in forum Mobile Java General
    Replies: 4
    Last Post: 2003-11-20, 23:14
  5. Audio Capture in Java
    By larrydb in forum Mobile Java Media (Graphics & Sounds)
    Replies: 4
    Last Post: 2003-08-25, 15:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×