×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    2

    Unhappy E60 web browser and passwords for https pages

    Hi Nokia guys,

    I have Nokia E60 phone. I need to use web browser to access https sites
    (Corporate intranet). Everything works fine except one annoying bug:
    When the browser makes a connection to https it asks me for
    "Phone key store password"
    where the certificate passwords are stored.
    It is OK for the first time. But it asks me everytime it downloads
    the image on the page.
    Imagine there are 20 images on the page.
    I have to write down the password 21 times.
    It effectively kills the https access.

    Some other browsers on PC ask for security password only once in some
    time period (like 1 hour).

    Please fix this bug or tell me some workaroud.
    I have s60 brower v 3.0 (0550).

    Thank you.

    Regards,
    Marek

  2. #2
    Registered User
    Join Date
    May 2006
    Posts
    1

    Re: E60 web browser and passwords for https pages

    I have another problem with my NOKIA E60. This problem is with intenet browser too. When I try to login in sites: www.betandwin.com www.azartas.net and I want to enter password, the browser turns off. This is very annoying. So I hope you will repair this bug. My browser is: S60 V. 3.0 (0550)

  3. #3
    Registered User
    Join Date
    Jun 2006
    Posts
    1

    Unhappy Re: E60 web browser and passwords for https pages

    Same here with www.hattrick.org.

    Though it lets me browse it for 1-2 mins before shutting down.
    Exactly the same version of browser as you have.

    There is a frame that reloads itself every minute or so.
    I think this is related to the reload since timeframe of browser shutting itself down seems to fit it.

    [edit]
    Tried the www.betandwin.com and it does exactly the same on my phone
    [/edit]
    Last edited by jussimannynoksa; 2006-06-14 at 22:29.

  4. #4
    Registered User
    Join Date
    Sep 2006
    Posts
    6

    Re: E60 web browser and passwords for https pages

    Quote Originally Posted by marekfort
    Hi Nokia guys,
    <cut>
    When the browser makes a connection to https it asks me for
    "Phone key store password"
    where the certificate passwords are stored.
    It is OK for the first time. But it asks me everytime it downloads
    the image on the page.
    Imagine there are 20 images on the page.
    I have to write down the password 21 times.
    It effectively kills the https access.

    <cut>
    Regards,
    Marek
    I'm having the exact same problem with my N80. Both with Opera and the Nokia browser, I am asked to type in the key store password several times for each page I'm loading. This makes the phone useless for my needs.

    Please advice!

    Regards,
    Trygve

  5. #5
    Super Contributor
    Join Date
    May 2003
    Posts
    839

    Re: E60 web browser and passwords for https pages

    Hi,

    could you send the links to those problematic pages, so I can also test those.

    Because problem can also be on server side, because there has been same problems also with different manufactures browser (Opera).


    -tum-

  6. #6
    Registered User
    Join Date
    Sep 2006
    Posts
    6

    Re: E60 web browser and passwords for https pages

    Hi,

    Thanks for you reply.
    In my case, these are intranet pages. They wouldnt work on any other server, and they cant be accessed without a certificate (which I cannot distribute).
    The setup is quite common though. An Apache/mod_ssl server set up to only allow access to users with a certificate, and we generate personal certificates for each user with OpenSSL.

    I've been in contact with Opera about this. They told me that they were aware of it, but that it was an issue Nokia would have to fix. Besides, the same problem arises when trying to use the Nokia browser.

  7. #7
    Registered User
    Join Date
    Oct 2006
    Posts
    1

    Re: E60 web browser and passwords for https pages

    I am not sure if this and fits also in your environment:

    S60 Platform: Creating and Installing Certificates Using SBS IIS Server and XCA

    Greetings,

    RL

  8. #8
    Registered User
    Join Date
    Sep 2006
    Posts
    6

    Re: E60 web browser and passwords for https pages

    Yes, that is pretty much our approach - but with one important diffrence.
    In the pdf, a CA certificate is installed on the phone to trust the server. In my situation (banks often use similar authentication), I also make a personal certificate and sign it with my CA. Apache will check that the clients browser has this certificate installed before allowing access. It is as far as I know loading the last certificate that fails.

  9. #9
    Registered User
    Join Date
    Sep 2006
    Posts
    6

    Re: E60 web browser and passwords for https pages

    Is there anywhere else to get support for this kind of problems?
    I called Norwegian Nokia support which - off course - had no clue what I was talking about. Curiously enough, they claimed to have _no_ means of escalating my call and simply referred me to this forum.

  10. #10
    Super Contributor
    Join Date
    May 2003
    Posts
    839

    Re: E60 web browser and passwords for https pages

    In this site has also professional support section.
    Technical Service - Technical Support ....
    There can be bought support from Forum Nokia to solve your problem.
    First registed and something, but there is more instructions what to do.

    -tum-

  11. #11
    Registered User
    Join Date
    Sep 2006
    Posts
    6

    Re: E60 web browser and passwords for https pages

    Quote Originally Posted by Tumpelo
    In this site has also professional support section.
    Technical Service - Technical Support ....
    There can be bought support from Forum Nokia to solve your problem.
    First registed and something, but there is more instructions what to do.

    -tum-
    Might just be me, but I find it curious that you have to pay to get bugs in the OS fixed..

  12. #12
    Registered User
    Join Date
    Nov 2006
    Posts
    1

    Re: E60 web browser and passwords for https pages

    I'm just confirming the (improper) behaviour. My device is an E61.

    I'm accessing a corporate intranet server (https) from "outside", using a certificate signed by an internal CA.

    This same certificate works perfectly on my PC(s) (both linux, and windows,
    in firefox and in IE).

    It adds fine to the keystore, and initially loads up the https page
    just fine (after querying for the password to the keystore).

    Thereafter, I get queried for the password to the keystore EVERY SINGLE
    TIME I click a link which points to the same website. This makes the
    https access absolutely useless.

  13. #13
    Registered User
    Join Date
    Dec 2006
    Posts
    6

    Re: E60 web browser and passwords for https pages

    Has a resolution been found yet for this problem? This is stopping my organization from deploying these phones for remote access to our intranet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×