×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    12

    sis Installer: "Feature not supported"

    First I've to say I'm a absolute newby in Symbian - I'm currently trying to build sis-installer-file for S60 N7610. I was happy to be able to create a file - but it doesn't work...
    I've got 2 swf-files (FlashLite) that I intend to integrate within the sis - FlashLite is running and the files itself either - but after creating the sis-file with makesis following error comes up on the mobile "Installer: "Feature not supported""

    here the code of the pkg-file:

    Code:
    &EN
    
    #{"FLASH LITE CONTENT"},(0x0100000),1,0,0
    ;TYPE=SISOPTION if I use SISOPTION it comes up with an error 
    ;while creating
    
    
    %{"Vendor-EN"}
    :"Vendor"
    
    ;Supports Series 60 v 1.0 or later
    (0x101F795F), 0, 0, 0, {"Series60ProductID"}
    
    "EL00.swf" - "!:\documents\flash\dir1\EL00.swf"
    "EL01.swf" - "!:\documents\flash\dir1\EL01.swf"

    ;I'm not sure about the directory structure on a mobile - can that cause an error?

  2. #2
    Nokia Developer Champion
    Join Date
    Apr 2005
    Location
    Boston
    Posts
    517

    Re: sis Installer: "Feature not supported"

    Ciao,
    try the following code for your pkg file. It should work. Let me know if you still have problems.

    ;Languages
    ;&EN
    ;
    ; UID is the app's UID
    ;
    #{"Application name"},(0x01234567),1,0,0,TYPE=SISAPP
    ;
    ;Supports Series 60 v 1.0
    (0x101F6F88), 0, 0, 0, {"Series60ProductID"}
    ;
    ; Display Release notes
    ;
    ;
    ; Files to install
    "EL00.swf" - "!:\documents\flash\dir1\EL00.swf"
    "EL01.swf" - "!:\documents\flash\dir1\EL01.swf"

  3. #3
    Registered User
    Join Date
    May 2006
    Posts
    12

    Re: sis Installer: "Feature not supported"

    I had to modify your code a bit and to use the Language & Vendor-name to create a pkg. But the file still isn't running - still the same error message :( - Haven't I to choose series v2? I'm confused by all those different formats; does that meen that I've to create for each mobile type it's own sis-installer files? - That's a hell of work :o


    Code:
    ;Language
    &EN
    
    #{"Application name"},(0x01234567),1,0,0,TYPE=SISAPP
    ;
    
    ;Localised Vendor name
    %{"Vendor-EN"}
    
    ;Unique Vendor name
    :"Vendor"
    
    ;Supports Series 60 v 1.0
    (0x101F6F88), 0, 0, 0, {"Series60ProductID"}
    ;
    ; Display Release notes
    ;
    ;
    ; Files to install
    "EL00.swf" - "!:\documents\flash\dir1\EL00.swf"
    "EL01.swf" - "!:\documents\flash\dir1\EL01.swf"

  4. #4
    Nokia Developer Champion
    Join Date
    Apr 2005
    Location
    Boston
    Posts
    517

    Re: sis Installer: "Feature not supported"

    Ciao

    you really do not need the Language and Vendor.
    Also if you use 0x101F6F88 it will install on all Symbian S60 phones.

    What is the error? Can you post it ?
    Alessandro

  5. #5
    Registered User
    Join Date
    May 2006
    Posts
    12

    Re: sis Installer: "Feature not supported"

    Indeed Language hasn't a effect!
    If I don't use the Vendor, makesis makes trouble and gives me that:
    Code:
    Processing test.pkg...
    No verndor names found.
    
    error: bad language count.
    I've installed Symbian 9.1 - in case that info helps.

  6. #6
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: sis Installer: "Feature not supported"

    The 7610 (http://www.forum.nokia.com/main/0,,0...tml?model=7610) is a 2nd edition FP1 device (Symbian OS v7.0s). Downgrade your SDK and try again.

  7. #7
    Registered User
    Join Date
    May 2006
    Posts
    12

    Re: sis Installer: "Feature not supported"

    hui - that isn't compatible downwards? What happens when I want to provide sis-files for newer and older devices - do I have always to up/downgrade the SDK?

    I've uninstalled the SDK 9.1 and have now the new files of the "2nd edition FP1" installed in a folder named Series_60_MIDP_SDK_2_1 - but I can't find the makesis.exe anymore? Is it included in that version?

    When I'm using the old makesis.exe there are still occuring the same errors.

    Hope you've got still some suggestions - thanks for your help so far !

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: sis Installer: "Feature not supported"

    Quote Originally Posted by wommwomm
    that isn't compatible downwards? What happens when I want to provide sis-files for newer and older devices - do I have always to up/downgrade the SDK?
    :-D If you pick some random topics containing "3rd" in their title, you will see that there are severe changes in Series60 3rd edition (or Symbian OS 9.x if you like) in comparison to all previous versions. Indeed you are lucky that you do not have to start with 3rd edition. Or not (since you will probably have to learn that someday). Anyway, there are a lot more pre-3rd edition S60 devices in the world, if you consider marketing or just testing opportunities.

    I've uninstalled the SDK 9.1 and have now the new files of the "2nd edition FP1" installed in a folder named Series_60_MIDP_SDK_2_1 - but I can't find the makesis.exe anymore? Is it included in that version?
    Series 60 MIDP SDK is for Java development I suppose. Download the one from the C++ tools page.

  9. #9
    Registered User
    Join Date
    May 2006
    Posts
    12

    Re: sis Installer: "Feature not supported"

    OK - will try to install this Tomorrow & will get back, telling if it is running - Today I've got some other stuff to do. I'm really optimistic, that it will work!
    One other quick question: Are Series60 3rd edition-devices able to run sis-files of older SDK like the 2nd edition FP1 device one? Hope it is upwards compatible - wouldn't make sense if not.

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: sis Installer: "Feature not supported"

    Quote Originally Posted by wommwomm
    Are Series60 3rd edition-devices able to run sis-files of older SDK like the 2nd edition FP1 device one? Hope it is upwards compatible - wouldn't make sense if not.
    No. You have to modify the paths, some portions of the code, and recompile it for 3rd edition. There are both binary and source compatibility breaks in the new OS.

  11. #11
    Registered User
    Join Date
    May 2006
    Posts
    12

    Re: sis Installer: "Feature not supported"

    Yes - works well now - Thanks - still one question -
    How can I install the file in a folder like Games - I've found lots of questions about that within the forum - but not a propper answer?

Similar Threads

  1. Replies: 2
    Last Post: 2010-05-26, 10:30
  2. Replies: 2
    Last Post: 2009-07-14, 01:16
  3. Why does SIS Installer NOT work on certain phones?
    By bpinvest in forum General Development Questions
    Replies: 4
    Last Post: 2006-02-21, 22:44
  4. Replies: 1
    Last Post: 2004-12-13, 23:17
  5. EPOC "Feature not supported"
    By creeder0 in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2004-04-16, 08:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×