×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    4

    Help: Some problems with AT command

    I'm building a small app for PC like Nokia PC suit. I use 8210 and 6220 to test the app but there are some strange problems

    1. Why Max of Name field in the response is difference from real phone? +CPBR: (1-250),20,8 -> is mean that Max of Name field is 8 characters but if I add an entry in phone, max of name field is 14 characters.

    PC: AT
    8210: OK
    PC: AT+CPBS="SM" -> select SIM storage
    8210: OK
    PC: AT+CPBR=?
    8210: +CPBR: (1-250),20,8
    8210: OK

    2. Why Nokia 6220 don't accept some AT commands (command related to phonebook?) -> is there AT command set for only NOKIA products ? because it is read by Nokia PC Suit in normal.

    PC:AT
    6220: OK
    PC: AT+CMGI -> manufacturer
    6220: Nokia
    PC: AT+CMGF=1 -> set text mode
    6220: OK
    PC: AT+CPBS="SM"
    6220: ERROR

    3. With the same code to read phone book, ME first then SM later is okie but in opposite is not okie ??? In Vietnamese, there are 2 GSM network: Vinaphone and Mobiphone. I tested with Mobiphone SIM, it's okie whatever SM or ME read first, but if I test with Vinaphone SIM, it's only okie if I read ME first. -->> are there any different SIM types and its properties ?

    03:49:03 Request : AT -> testing AT command
    03:49:05 Response: OK
    03:49:05 Request : AT+CPBS="SM"
    03:49:05 Response: OK
    03:49:05 Request : AT+CPBR=?
    03:49:05 Response: +CPBR: (1-250),20,8
    03:49:05 Response: OK
    03:49:05 Request : AT+CPBR=1,250
    03:49:06 Response: AT+CPBR=1,250<CR><CR><LF>
    03:49:06 Response: +CPBR: 1,"+84913393639",145,"A.DUNG.A T"<CR><LF>
    03:49:06 Response: +CPBR: 2,"0904266966",129,"A.CHUNG.A T"<CR><LF>
    03:49:06 Response: +CPBR: 3,"0989242212",129,"LINH.VIETTEL"<CR><LF>
    03:49:06 Response: +CPBR: 4,"0983388295",129,"CUONG.A9"<CR><LF>
    03:49:08 Response: OK
    03:49:08 Request : AT
    03:49:14 Response: Time out, no response.

    Thanks you so much for your help and I'm sorry about my English (I'm Vietnamese)

  2. #2
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: Help: Some problems with AT command

    oh, so you know what your doin...
    Jason Glass
    http://IChiBanComputers.Com

  3. #3
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: Help: Some problems with AT command

    my 6630, doesnt even allow access, or doesnt reconize any of those commands, relating to pbook and storage, all i can do is send(not receive)sms.

    bytes...and good luck!
    Jason Glass
    http://IChiBanComputers.Com

  4. #4
    Registered User
    Join Date
    May 2006
    Posts
    4

    Re: Help: Some problems with AT command

    I think my 6220 and your 6630 does not fully support AT command, so maybe Nokia products use Nokia's AT command like Sony Ericsson. I have an AT command set for Sony Ericsson, there are many commands are written for only Sony Ericsson. http://www.megaupload.com/?d=WN6XE65Q

  5. #5
    Registered User
    Join Date
    Jul 2006
    Posts
    1

    Re: Help: Some problems with AT command

    I have a question:
    Nokia 8250 can send/recive SMS through COM port?
    Anybody, pls help me.
    Thanks

  6. #6
    Super Contributor
    Join Date
    Mar 2006
    Location
    Phoenix, AZ. USA
    Posts
    556

    Re: Help: Some problems with AT command

    you just have to generally try to send the sms, follow the steps below, or search forums for other posts in relation to testing the sending of sms using com ports/hyperterminal

    good luck

    PS: if it does support it, you could always post back to hear, so we know the device supports it!
    Jason Glass
    http://IChiBanComputers.Com

Similar Threads

  1. Getting started with Carbide.vs -- running the app
    By ET3D in forum Symbian Tools & SDKs
    Replies: 6
    Last Post: 2005-11-23, 17:45
  2. problems with CMGL command
    By radura in forum General Messaging
    Replies: 7
    Last Post: 2005-01-29, 16:08
  3. Replies: 1
    Last Post: 2003-03-29, 20:10
  4. Replies: 1
    Last Post: 2003-03-24, 20:04
  5. nokia 7210 modem via IR doesn't work !
    By oussamaaiadi in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2003-03-06, 10:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •