×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    3

    S60 v3 initial help with CodeWarrior

    Hi to all, this is my first post!!
    i got a little problem with compiling an easy application for S60 version 3. The application doesn't have problem because i downloaded the source code from a manual somewhere and it worked fine on the emulator. when i change the default target in codewarrior from WINSCW UDEB (the one of the emulator) to GCCE UREL (the one for the real phones) i got a warning that says that only 1 file has been created and effectively i can't find the file .pkg that i need to generate the .sis one. What can i do???
    I hope i hadn't been ambiguous or not very clear and if you can help me please.

    Cloud

  2. #2
    Registered User
    Join Date
    Feb 2005
    Posts
    48

    Re: S60 v3 initial help with CodeWarrior

    Hi,

    When you are compiling the project with GCCE compiler Carbide automatically tries to generate .sis installation packet which you can then install to your phone. Before .sis packet can be done Carbide needs <application_name>.pkg. This file contains all needed info to generate sis packet. Please read following chapter from Carbide.C++ help: "Working with PKG and SIS Files".

  3. #3
    Registered User
    Join Date
    May 2006
    Posts
    3

    Re: S60 v3 initial help with CodeWarrior

    First i installed Carbide.c++ and i made a wizard configuration for a new project. The "Introductory white paper" guide provided from the nokia forum site offers an example to create a first application ( helloWorld ). I followed the steps BUT (there's always a but ^_^ ) i have 2 errors and several warnings. First error says that the compiler is unable to find a c:\Documents.bmp file so I create a file and renamed Documents.bmp and putted into the root directory (and that worked fine), the second one says that it's unable to find the file and.bmp (and this time i don't know how to do and/or where to put its).
    The warnings regards lables used but not declared and something that says:
    "the STRUCT that this resource is based on contains a STRUCT[] data member which has not been used in this resource, the missing element is: 'name_of_the_element' HelloWorld_reg.rss HelloWorld/data"
    My questions are 2:
    1) why a wizard provides that kind of errors/warnings?
    2)what can i do to compile this application without errors and warnings and run it on my phone????

    Thanks in advance for the attention and the help.

    Cloud

  4. #4
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: S60 v3 initial help with CodeWarrior

    Well, you would have needed to read the Installation guide to find out that the workspace in Eclipse needs to be somewhere where the path has no blanks, so the default actually does not work. Just change your workspace and you should be fine.

  5. #5
    Registered User
    Join Date
    May 2006
    Posts
    3

    Re: S60 v3 initial help with CodeWarrior

    I changed the path and errors disappeared (thanks!!!) but several warnings remained... they refers to inclusions...something like this:

    in inclusion C://Symbian//9.1//S60_3rd//epoc32//include/eiksrvs.h:14: [C://Symbian//9.1//S60_3rd//epoc32//include/eiksrvc.h] HelloWorld line 9

    or something like a label that is used but has not been declared...
    i tried anyway to install the sis file on my phone (a nokia 3250) but the installation has being blocked because the provider has not being recognized as a valid software provider (i think it's a problem of signature or similar but i don't know how to resolve it)...
    so in order what i have to do to install this application on my phone?

    Thanks in advance.

    Cloud

Similar Threads

  1. Change from CodeWarrior to Carbide. When, how and how much
    By petxolobo in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-05-08, 22:06
  2. Codewarrior does not create correct dependencies on s60
    By rburgst in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2005-05-25, 16:59
  3. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36
  4. Question about migrating from .NET to CodeWarrior
    By gdzzt in forum Symbian Tools & SDKs
    Replies: 3
    Last Post: 2004-09-11, 13:30
  5. Almost all tools (S60 MIDP SDK B0.1, Nokia S60 SDK Symbian OS v0.3) Crashes
    By alexandershalamov in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2002-07-03, 13:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×