×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    50

    the smil seems can't work in Nokia7650?

    Hi,
    I write the smil like follow:
    <smil><head><layout><root-layout width="100%" height="100%"/>
    <region id="region1_1" top="0" left="0" height="100%" width="100%"/>
    </layout>
    </head>
    <body>
    <seq>
    <par dur="3000ms">
    <img src="BBT20506_panel00.jpg" region="region1_1"/>
    </par>
    <par dur="3000ms">
    <img src="BBT20506_panel01.jpg" region="region1_1"/>
    </par>
    <par dur="3000ms">
    <img src="BBT20506_panel02.jpg" region="region1_1"/>
    </par>
    <par dur="3000ms">
    <img src="BBT20506_panel03.jpg" region="region1_1"/>
    </par>
    <par dur="3000ms">
    <img src="BBT20506_panel04.jpg" region="region1_1"/>
    </par>
    </seq></body></smil>

    But when send to the Nokia 7650, it can't work properly.
    1) I want the picture disply full screen
    Is that right in "<root-layout width="100%" height="100%"/>"?
    2)actually I get this smil from ericsson mms composer.
    is the <seq></seq> right for Nokia7650?
    3) <par dur="3000ms">, weather can I use 'ms' here?

    It's urgent. Please help me out. Thanks advanced.

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Tampere / Finland
    Posts
    1,839

    RE: the smil seems can't work in Nokia7650?

    Hello!

    Please see "How to create MMS services" document at page 17.

    Teemu / Forum Nokia

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    50

    RE: the smil seems can't work in Nokia7650?

    Sorry. But can't show the SMIL script here? I display it as image again. <img src="http://www.pheephoo.com/temp/smilpic.jpg">
    Please advice what's wrogn in this smil.

  4. #4
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    474

    RE: the smil seems can't work in Nokia7650?

    To answer your question 2 - regarding use of <seq>: NO, use of <seq> is most definitely incorrect. <body> is by definition a sequential container.

    As to your SMIL problems, be sure you are setting the type of the message correctly....

    m.setContentType(IMMConstants.CT_APPLICATION_MULTIPART_RELATED);
    m.setMultipartRelatedType(IMMConstants.CT_APPLICATION_SMIL);
    m.setPresentationId("<0000>"

    -paul / ForumNokia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×