×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    2

    JSR 177 and Nokia 3250

    I'm working in the SIM industry , I bought the nokia 3250 to test JSR 177 for APDU.
    The program is simple and should be no trouble to work on this hanset; my problem is that the midlet is install without problem but i cannot lunch the application.

    I wonder if nokia did not implement APDU package.
    All the paper i read from them say that they will support it on the 3th edition S60.

    It will be nice from nokia to clarify what their 3th edition will really support on JSR 177 , because bying an hanset at 400 dollars for nothing is not nice.

    PS: for many people support 177 will means APDU support.

  2. #2
    Super Contributor
    Join Date
    Feb 2006
    Posts
    689

    Re: JSR 177 and Nokia 3250

    Hi blastard,
    You are right.Also in nokia device specification it is said that 3250 will support jsr 177.
    Thanks
    Soku

  3. #3
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    151

    Re: JSR 177 and Nokia 3250

    Ya You are right some people are having problems with 3250 so you should first check it
    Cheers,
    Manan

  4. #4
    Registered User
    Join Date
    May 2006
    Posts
    2

    Re: JSR 177 and Nokia 3250

    I waited too much for this handset to start to work on it, it's a big disappointment.

    it's necessary for Nokia to clarify this JSR 177 issue , at least http://www.forum.nokia.com/main/0,,0...tml?model=3250 tell under 177 that only crypto and PKI is supported.

  5. #5
    Super Contributor
    Join Date
    Mar 2006
    Posts
    516

    Re: JSR 177 and Nokia 3250

    Hi Blastard,

    From the JSR 177 documentation it is seen that APDU is an optional package in addition to the optional packages like security api like Crypto and PKI.
    Since it is an optional packages it is upto the phone manufacturers to decide which all optional packages to be present in the phone.

    Any way Nokia should have mentioned which all optional api packages are provided and which all are yet to be implemented under one JSR.

    We had a discussion on this
    http://discussion.forum.nokia.com/fo...ad.php?t=77288

    Wang

  6. #6
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: JSR 177 and Nokia 3250

    As already mentioned on this thread, S60 3rd edition supports PKI and Crypto optional packages from JSR-177. The optional packages APDU and JCRMI are not supported.

    Hartti

  7. #7
    Super Contributor
    Join Date
    Feb 2006
    Posts
    689

    Re: JSR 177 and Nokia 3250

    Hi,
    If The optional packages APDU and JCRMI are not supported,it should be notified in the device specification.
    Thanks
    Soku

  8. #8
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: JSR 177 and Nokia 3250

    Soku, duly noted. I'll pass this comment to our documentation team.

    Hartti

  9. #9
    Registered User
    Join Date
    May 2007
    Posts
    6

    Re: JSR 177 and Nokia 3250

    hi everybody

    is there any phone where i can test jsr - 177 (SATSA-APDU) api.

    plz it is very urgent.

  10. #10
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,430

    Re: JSR 177 and Nokia 3250

    Quote Originally Posted by anik_gnr
    hi everybody

    is there any phone where i can test jsr - 177 (SATSA-APDU) api.

    plz it is very urgent.
    If I remember it correctly, I have read some where that APDU package is available in Series 40 3rd Edition Feature Pack 2 phones and not in any S60 device as of now.

    Regards
    Gopal

    __________________
    MobiQuil.com
    An initiative by Developers for Developers.
    http://www.mobiquil.com - Alpha - Launched.

  11. #11
    Registered User
    Join Date
    May 2007
    Posts
    6

    Exclamation Re: JSR 177 and Nokia 3250

    thanks,

    nokia should implement this package.

  12. #12
    Nokia Developer Champion
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,192

    Re: JSR 177 and Nokia 3250

    As MSA-specification (JSR-248) includes JSR-177 and defines that APDU, CRYPTO, and PKI optional packages need to be implemented, also APDU will be more widely available on different phones in the future.

    Hartti

Similar Threads

  1. J2ME > javacard communication (JSR 177)
    By jeremy.carre in forum Mobile Java Networking & Messaging & Security
    Replies: 23
    Last Post: 2011-04-10, 19:23
  2. Nokia 3rd Generation support for JSR 177
    By muenni79 in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2006-03-24, 10:21

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •