Hi,

I am trying to write a server socket program on E60 (S60 3rd) via Wireless connection. But the connection from client to server is not always success. Therefore, I tried to find out when the connection can be made. Many weird things happened.

First, I ping 192.168.1.210 (E60's IP).
Request timed out.
Reply from 192.168.1.210: bytes=32 time=48ms TTL=69
Reply from 192.168.1.210: bytes=32 time=17ms TTL=69
Reply from 192.168.1.210: bytes=32 time=13ms TTL=69
Reply from 192.168.1.210: bytes=32 time=16ms TTL=69
Request timed out.
Request timed out.
Request timed out.


The connection succeed when ping reply OK and fails when ping time out.
Ping reply OK only when the first few seconds after IAP is selected. After that, ping always time out.

I check the Wireless status from Conn. Mgr. and found that the status shows interlace of active and inactive. The status changes all the time instead of always active.

Then I use E60's SIP phone and X-Lite for test. A successful SIP call from X-Lite to E60 exists only when ping is OK.

Web browsing ofter gets "connection timeout" message.

Then I connect E60 and my notebook in ad-hoc mode. Everything goes fine. The connection always can be made and last till disconnction manually.

I think the cause may be the incompatibility of access point. Therefore, I tried D-Link DWL-900AP+, Cisco AIR-AP1120B, Corega CG-WLBARGP, Asus WL-700GE. None of them can let E60 connect to WLAN all the time. The connection exists only feww seconds.

Is it possible the bug of E60 WLAN? Wrong firmware? Or I got a damaged E60?