Hi, we are experiencing problems with the networks settings most swedish telecos are sending out to S40 phones. Tele2, Vodafone and Telia send settings that worked for WAP, but not for java applications. To get around the problem you had to create your own apn with the settings from the telecos, and set that apn as prefered. It then worked, however using those settings, IPX no longer would accept any charges, because the user is not comming from an authorized wap gateway (we are doing http request from inside the midlet). We have contacted IPX, and they were unaware of the problem. They did accnowledged that the ips that were trying to get charged were coming from a place not set up as wap-gateways (a firewall from vodafone if I remeber correctly). Quite odd.

Just recently Telia changed the way theire OTA works, and not theire settings works. However, tele2 and vodafone(telenor) still does not work.

One odd thing is that if you use the settings that comes with the phone (its preloaded with the most common telecos) everything works. Since those settings are locked, we can't see if there is something special with them, but obviously something is wrong with the ones we create.

Can someone help us out here?

/Bjorn