×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    5

    empty square on xhtml

    Hi,

    I have browsed for threads about empty square.. but couldn't find any solutions.. We are developing wap pages with xhtml. All pages have utf8 as encoding and its works fine. But on most of nokia devices we are getting some empty square. Even if we trimmed the string some get empty square at the end of the string, but some on middle of the line..
    Do any body know a solution for this problem.. ?

    Plz help..

  2. #2
    Registered User
    Join Date
    May 2006
    Posts
    8

    Re: empty square on xhtml

    Hai,
    Can you please post your code here .....I think that might be helpful in finding a solution for the problem.

    Regards
    Chinna

  3. #3
    Registered User
    Join Date
    May 2006
    Posts
    5

    Re: empty square on xhtml

    Oki.. i Found the bug.. When i used the Opera setting encoding explicit to utf-8 i get this.. �. This charecter is coming after i have trimmed the string.. But ist strange that all other charecter like ø,æ, å is getting right encoding in utf8.

    This is the headder declaration:

    <!DOCTYPE html PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.0//EN" "http://www.wapforum.org/DTD/xhtml-mobile10.dtd">
    <html>
    <head>

    <link rel="stylesheet" href="/mobilportal/include/1100.jsp" type="text/css" />
    <meta http-equiv="expires" content="0" />
    <meta http-equiv="pragma" content="no-cache" />
    <meta content="application/vnd.wap.xhtml+xml" />
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    </head>

    And here is where the empty square problem comes.. :


    <div class="channels">
    <table class="props_outer" width ="100%">
    <tr>
    <td colspan="3">
    <b> Observation </b> KL.14:00, Budapest (Pestl�rinc)
    </td>
    </tr>
    <tr>
    <td>
    <img src="img/icon/weather/9.gif" alt="" />

    </td>
    <td> 15&deg;C </td>

    <td>
    Rainy.�
    </td>

    </tr>
    <tr>

    <td colspan="3">
    Easy rain�
    </td>

    </tr>
    </table>
    </div>

    "�" is showd as "[]"..

    Is there any fault on header declarations??

  4. #4
    Registered User
    Join Date
    Jun 2004
    Location
    HEL
    Posts
    36

    Re: empty square on xhtml

    Are you sure you are setting the headers correctly for this?
    Setting them within the document itself is not enough if the server doesn't automatically parse the content as UTF-8.

    You will need server side technology for this though. PHP, ASP etc....
    Cheers,

    Jamie

    # Any form of employment is strictly prohibited ......

  5. #5
    Registered User
    Join Date
    May 2006
    Posts
    5

    Re: empty square on xhtml

    Quote Originally Posted by jabba_29
    Are you sure you are setting the headers correctly for this?
    Setting them within the document itself is not enough if the server doesn't automatically parse the content as UTF-8.

    You will need server side technology for this though. PHP, ASP etc....
    Thanks for your replay =) .. Yeep., we sat the encoding explicit, on server.xml from the Tomcat distribution.. And then removed the line in
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" /> since we allready had this line on all the pages:
    <%@ page contentType="application/vnd.wap.xhtml+xml;charset=UTF-8"%>.

    Now we are getting right encoding, non empty square...

Similar Threads

  1. A Jtidy and XHTML question
    By mikeliu1976 in forum Browsing and Mark-ups
    Replies: 1
    Last Post: 2004-09-30, 05:06
  2. Animation in XHTML via timer
    By barnsley in forum Browsing and Mark-ups
    Replies: 7
    Last Post: 2004-09-30, 04:51
  3. Browser Emulator - xhtml rendered as text
    By papasosa in forum Browsing and Mark-ups
    Replies: 2
    Last Post: 2004-05-11, 16:38
  4. define xhtml as mime-type in tomcat (URGENT)
    By tserivdd in forum Browsing and Mark-ups
    Replies: 1
    Last Post: 2004-05-06, 13:17
  5. XHTML WAP gateway problem?
    By huffschmid in forum Browsing and Mark-ups
    Replies: 0
    Last Post: 2004-04-07, 17:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×