×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    May 2006
    Posts
    3

    no discovery agent on nokia 6230??

    My bt app works fine with some devices. But the nokia 6230 fails to initialize the discovery agent. Anybody with similiar problems? is there anything nokia-specific to keep in mind when dealing with j2me bluetooth basics???

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    Not that I am aware off, however, I started with the Nokia 6230 as first device and then went to the other oceans. Try your MIDlet in the Nokia Series 40 Platform SDK in Version 1.1 which is the Nokia 6230. It is quite near a real device.

    The only things I noticed in Series 40, Bluetooth must be enabled by the user manually beforehand. It does not start automatically as it does on Siemens or Sony Ericsson. Additionally, there are no cached or known devices available and the return value is NULL. Furthermore, make sure there is no connection or name lookup active while searching for other devices or services as the Nokia Series 40 2nd Edition supports only one connection at a time.

  3. #3
    Registered User
    Join Date
    May 2006
    Posts
    3

    Re: no discovery agent on nokia 6230??

    Ok, i tried the series 40 platform sdk and get the same nullpointer exception as in the real device.
    "... Bluetooth must be enabled by the user manually beforehand." In the emulator as well? because strangely this is impossible. there's an option but the bluetooth state always stays disabled?!?!

  4. #4
    Regular Contributor
    Join Date
    Nov 2004
    Posts
    105

    Re: no discovery agent on nokia 6230??

    I've worked with a 6230 before and I can tell you that although discoveryAgent is fine for it - you can discover devices. Service Discovery is broken, like totally broken, like if you try to search for services this will cause an exception because the method isn't implemented for the 6230.

    What this means is you can look for devices - if you know the connection url for one device (you have to know the url - which changes by the way !!!) that is the only way you can connect !

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    Pardon? Which function does not work?
    I am working with a Nokia 6230 and everything is and was fine either in the most current or much older firmware versions.

  6. #6
    Regular Contributor
    Join Date
    Nov 2004
    Posts
    105

    Re: no discovery agent on nokia 6230??

    Well - when I used to work with it. It always threw an exception when you did something like
    DiscoveryAgent da = da.searchServices(RemoteDevice, AttributeSet, ..)

  7. #7
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    Works here. Never read anywhere about that. Which firmware was that? I think, you had/have a programming bug.

  8. #8
    Regular Contributor
    Join Date
    Nov 2004
    Posts
    105

    Re: no discovery agent on nokia 6230??

    was a firmware bug! My code is never wrong! (:
    Anyway was awhile back now, ported the same code to a 6600 and it worked fine.
    Just my 2 cents!

  9. #9
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    c_e , which firmware do you have on your Nokia 6230?

  10. #10
    Regular Contributor
    Join Date
    Nov 2004
    Posts
    105

    Re: no discovery agent on nokia 6230??

    Dunno and dont care now
    changed phones awhile back - just remember all the headaches of the past

  11. #11
    Registered User
    Join Date
    May 2006
    Posts
    3

    Re: no discovery agent on nokia 6230??

    ok, the problem is more fundamental: i get an bluetoothstateexception when trying to initialize the bluetooth stack. that leads me to the assumption that the user of the nokia 6230 always has to invoke the bluetooth connectivity manually beforehand, am i right?
    i am using the nokia emulator. why is it impossible to switch-on bluetooth there? how you guys use the emulator (nokia s40 dp20 sdk 6230i) when dealing with bluetooth applications???

  12. #12
    Registered User
    Join Date
    Mar 2003
    Posts
    4,105
    Yes, in Nokia JSR-82 world, the user has to set Bluetooth to On manually. In Nokia S60 world the user has to change the visibility manually, too.

    Not sure, what is wrong with the emulator. Are you running the Nokia Connectivity Framework?

Similar Threads

  1. Nokia User Agent Header
    By rajendrap16 in forum Browsing and Mark-ups
    Replies: 17
    Last Post: 2008-02-24, 15:43
  2. Infra-red capability
    By Symbian_Challenge_0412 in forum General Development Questions
    Replies: 1
    Last Post: 2005-08-16, 18:24
  3. Replies: 0
    Last Post: 2005-07-22, 21:27
  4. Replies: 0
    Last Post: 2004-07-11, 13:07
  5. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×