×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Jun 2006
    Posts
    9

    Problem with LandmarkStore

    Hello,
    I have another problem with my nokia S40 gps application: I get a NoClassDefFound error when I try to get the Landmarkstore.
    I don't think I've made a mistake since my program works fine on the emulator.

    If anyone knows about it, please let me know!
    Thanks.

  2. #2
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: Problem with LandmarkStore

    Hi bouncebounce,

    Please let us know which device you're talking about.

    BR,

    Juarez Junior

  3. #3
    Registered User
    Join Date
    Jun 2006
    Posts
    9

    Re: Problem with LandmarkStore

    As I said I'm using a Nokia S40 phone.

    The Landmarkstore class is defined in the Location API for J2ME (JSR 179)

    As soon as I try
    "LandmarkStore.getInstance(null);" or "createLandmarkStore(storeName);", I have the class not found error.

  4. #4
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: Problem with LandmarkStore

    Ok, bouncebounce, i know that, but which one?

    Juarez Junior

  5. #5
    Registered User
    Join Date
    Jun 2006
    Posts
    9

    Re: Problem with LandmarkStore

    Ok, sorry it is the 6280.

  6. #6
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: Problem with LandmarkStore

    Hi bouncebounce,

    This device doesn't implement JSR-179 - Location API. Below are its specs:

    http://www.forum.nokia.com/main/0,,0...tml?model=6280

    Hope it helps!

    BR,

    Juarez Junior

  7. #7
    Registered User
    Join Date
    Jun 2006
    Posts
    9

    AAAaaargl

    Ok thanks. I'll do something else then...

  8. #8
    Registered User
    Join Date
    Jun 2006
    Posts
    9

    Install the missing classes...

    Okay, I've downloaded the JSR-179. There is a jar inside with the classes I'm looking for. I've added it in the classpath of my project and put it in the phone, but it failed again...

    Anyone knows what I'm doing wrong ?

  9. #9
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: Problem with LandmarkStore

    Hi bouncebounce,

    You cannot install new APIs on the device, i mean, it must support JSR-179 by default.

    BR,

    Juarez Junior

Similar Threads

  1. J2ME: Problem in Nokia Solution for a software problem
    By mte01 in forum Mobile Java Tools & SDKs
    Replies: 4
    Last Post: 2011-06-08, 05:52
  2. problem when stop playing video on 3650 and try to play again
    By niko86 in forum Mobile Java General
    Replies: 5
    Last Post: 2007-08-03, 07:40
  3. Ringing problem with Nokia N70
    By DVogdos in forum Audio
    Replies: 2
    Last Post: 2007-06-26, 20:49
  4. Replies: 1
    Last Post: 2005-12-04, 12:01
  5. J2ME: Problem in Nokia Solution for a media problem
    By mte01 in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-08-12, 11:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×