×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Regular Contributor
    Join Date
    Jul 2005
    Posts
    89

    Exclamation MIDlet INSTALLATION ERROR on 6630

    Hi guys,
    I seem to be having a strange error...maybe i can't see properly
    I tried installing a MIDlet that is supposed to listen for incoming messages and after writing this MIDlet and testing on the JME and sony ericsson wireless toolkits using the "run via OTA" and utilities "WMA console", and it works fine.
    Now when i try installing it unto a real device(nokia 6630 and sony ericsson k300i) it refuses.
    On Nokia 6630, it refuses to install and says "unable to install:conversion error".
    on the ericsson, it installs but doesn't start up.

    and funny enough, i previously wrote & configured another MIDlet very similar using a tutorial, when i tried installing the midlet i wrote using the tutorial i learnt from...it worked well.
    But i now i try writing mine and its misbehaving ...below is the jad file content:

    MIDlet-1: SMSman, /myico.png, Teshinula
    MIDlet-Description: A MIDlet after my heart....hehehe
    MIDlet-Jar-Size: 31824
    MIDlet-Jar-URL: SMSman.jar
    MIDlet-Name: SMSman
    MIDlet-Permissions: javax.wireless.messaging.sms.receive,javax.microedition.io.Connector.sms,javax.microedition.io.PushRegistry
    MIDlet-Push-1: sms://:502, Teshinula, *
    MIDlet-Vendor: mobile test Inc.
    MIDlet-Version: 1.0
    MicroEdition-Configuration: CLDC-1.1
    MicroEdition-Profile: MIDP-2.0
    portobelo: 502


    what do you guys think is the problem.....need help

  2. #2
    Regular Contributor
    Join Date
    Jul 2005
    Posts
    89

    Unhappy Re: MIDlet INSTALLATION ERROR on 6630

    Ok guys it installed on the sony ericssons(k700i & 300i) but didn't install on the nokia 6630.
    testing on the ericsson, it sends messages but doesn't come up when a message is received by the phone.
    I directed sms(s) sent by my application to take the format "sms://+recepients_number:Application_portNumber
    The "Application_portNumber" i hard-coded into the application as 502.
    it doesn't seem to be functioning because when i sent the sms from the application in phone 1(k3001) it goes straight into the normal inbox of the other phone(k700i) instead of prompting my app.....what do you guys think is the problem?

    And why isn't nokia working for this.......it has to work on nokia or else i have not accomplished anything


    anybody gonna help?

  3. #3
    Regular Contributor
    Join Date
    Jul 2005
    Posts
    89

    Re: MIDlet INSTALLATION ERROR on 6630

    monday and still no answer........

  4. #4
    Registered User
    Join Date
    Jun 2006
    Posts
    2

    Re: MIDlet INSTALLATION ERROR on 6630

    Hi,

    We had the same error and we found our problem.

    The images (icons etc) for the midlet had been corrupted from some cvs transfers. So we copied in the correct icons, and recompiled and it worked.

    Hope that helps. Try out our midlet at http://m.eyetap.org

  5. #5
    Regular Contributor
    Join Date
    Jul 2005
    Posts
    89

    Re: MIDlet INSTALLATION ERROR on 6630

    Thanks fung

  6. #6
    Registered User
    Join Date
    Jan 2007
    Posts
    18

    Re: MIDlet INSTALLATION ERROR on 6630


    Hi,
    I have made j2me untrusted & unsigned midlet applications running in most of the java
    enabled handset .I have tested all applications in 6230 installing via data cable or OTA

    dirctly from server, running successfully.But same application when installing in

    6681(nokia 60 series)via data cable it displayed "code conversion error" & rebooted.After

    trying to install repetadly 6 & 7 times via data cable then it is successfully installed

    .After some days later when installing same applications via data cable sometimes

    displayed same "code conversion error" & sometimes installed properly.That is really

    unexpected behaviour!. what is the reason behind this?Can anyone help me about these?

    Also same application when installing via OTA directly from server in nokia 6230(series 40)
    it was installed & running fine .But when installing in nokia 6681 ( series 60)
    via OTA directly from server sometimes just prior to finish installation mobile is rebooted

    & application not installed .Although, sometimes it was installed successfully but after

    installation most of the time mobile is rebooted.Also if I tried to reinstall the

    application that is already exist via OTA in nokia 6681 it shown same "code conversion

    error" & then rebooted.
    (1) What may be the reasons before prior to finish installation via OTA it is rebooted ?

    (2)why most of the time after successful installation it is rebooted?
    (3)if I try to reinstall the application that is already exist via OTA in nokia 6681 it

    shown same "code conversion error" and then rebooted, but not in case of 6230 that is

    working fine .
    It is very urgent!.Please help me about all sort of these problems.

  7. #7
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: MIDlet INSTALLATION ERROR on 6630

    @ sumanbera :: Please dont make multiple posts in same regard, you already have replies here
    http://discussion.forum.nokia.com/fo...ad.php?t=99367

    Regards
    Gopal

    __________________
    MobiQuil.com
    An initiative by Developers for Developers.
    http://www.mobiquil.com - Alpha - Launched.

Similar Threads

  1. Launching a 3rd-party Trusted Java Midlet on Nokia 6630
    By vichoty in forum Mobile Java Networking & Messaging & Security
    Replies: 3
    Last Post: 2012-06-23, 15:21
  2. self signed midlet installation problem on 3250
    By siva_guduru in forum Mobile Java General
    Replies: 1
    Last Post: 2006-05-04, 08:11
  3. N70 midlet installation not possible
    By age85 in forum Mobile Java Networking & Messaging & Security
    Replies: 4
    Last Post: 2006-03-27, 13:01
  4. Installation failed with signed MIDlet (Invalid revocation server)
    By greusser in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2005-02-25, 08:32
  5. MIDlet removed during installation
    By jmsalvo in forum Mobile Java General
    Replies: 3
    Last Post: 2003-09-29, 21:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×