×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    May 2005
    Posts
    15

    fca.zip Invalid API package ?

    I am on NetBeans 5.0, J2ME platform Noki Prototype SDK 4.0 Beta, and when i am adding file
    connection permissions to my MIDlet, it is OK for the javax.microedition.io.Connector.file.read,
    but for the avax.microedition.io.Connector.file.write it says "Invalid API package" !
    Do you know the reason ?
    the package is the C:\Nokia\Nokia_Prototype_SDK_4_0_Beta\devices\Prototype_4_0_Beta_S40_240x320_MIDP_Emulator\lib\ext\fca.zip,
    (25671 bytes). ...
    Thanks for any help !
    jldo.

  2. #2
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: fca.zip Invalid API package ?

    Hi douville,

    I cannot see the reasons why it's happening. Are you sure there's no typo, i noticed that your post says:

    avax.microedition.io.Connector.file.write


    No "j" at the beginning. Did you copy it verbatim from your project?

    BR,

    Juarez Junior

  3. #3
    Registered User
    Join Date
    May 2005
    Posts
    15

    Re: fca.zip Invalid API package ?

    It was just an error while typing : javax.microedition.....
    But i think that the reason could be that the Prototype_4_0_Beta_S40_240x320_MIDP_Emulator platform does not support File Connection API. But why the read permission is accepted but not the write ?

  4. #4
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: fca.zip Invalid API package ?

    Hi douville,

    I'm not sure about Prototype SDK 4.0 Beta but the final version - Nokia Prototype SDK 4.0 for Java(TM) ME (10 January 2006) does support it. Maybe you could give it a try and install a newer version.

    Hope it helps!

    BR,

    Juarez Junior
    Last edited by juarezjunior; 2006-06-07 at 02:26.

  5. #5
    Registered User
    Join Date
    May 2005
    Posts
    15

    Re: fca.zip Invalid API package ?

    OK, i have replaced the beta 4.0 SDK by the 4.0 SDK. With the S40_240_320 Emulator, and fca.zip added in the libraries : it says OK for javax.microedition.io.Connector.file.read, but "Invalid API package" for javax...file.write :-(

  6. #6
    Registered User
    Join Date
    May 2006
    Posts
    2

    Re: fca.zip Invalid API package ?

    I am getting the same "Invalid API message" when I want to allow file writing. Would love to know what to do to solve the problem if possible.

  7. #7
    Registered User
    Join Date
    Dec 2005
    Location
    Brazil
    Posts
    1,884

    Re: fca.zip Invalid API package ?

    Hi there,

    I cannot see the reasons why it's happening, ufortunately. Let's see if someone else has a tip on that, though.

    BR,

    Juarez Junior

Similar Threads

  1. PC Suite error: (Code: Init IMediaControl2) HELP?!
    By chunkyspudmonkey in forum General Development Questions
    Replies: 30
    Last Post: 2014-07-15, 05:44
  2. package install 6230i ok, but invalid
    By fabalint in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2006-05-02, 21:34
  3. User Comments and Examples into API Docs
    By jyrkiettila in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 4
    Last Post: 2006-04-21, 11:04
  4. How to play AMR file in Nokia3200 using Nokia UI API
    By amitkumar_j2me in forum Mobile Java Media (Graphics & Sounds)
    Replies: 1
    Last Post: 2005-06-16, 09:14
  5. Creting Application package fileNotFound error
    By pid0101 in forum Mobile Java General
    Replies: 0
    Last Post: 2004-01-19, 19:55

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×