×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Sep 2003
    Posts
    37

    N80 Jad error: Compulsory attributes missing

    Hello all!
    I get the above message: ("Compulsory attributes missing") when trying to download a game through a link to its jad file...
    Did anyone encounter this problem?
    The stranger thing is that it happens only when I go through a servlet that is giving me the jad. If I go directly to the jad, it works great... (Same jad, 100%)

    Insights anyone?

    Thanks a lot!

  2. #2
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: N80 Jad error: Compulsory attributes missing

    In case you have missed, do you have proper MIME types of JAD/JAR in your server?
    Please make sure that you have correct "MIDlet-Jar-URL:" in your JAD file. Also would like to know whether you have tried in any other device, Does it work fine?

    Regards
    Gopal

  3. #3
    Super Contributor
    Join Date
    Mar 2006
    Posts
    516

    Re: N80 Jad error: Compulsory attributes missing

    Hi,

    please check whether all the jad & manifest entries are correct.
    can u please post all the jad & manifest entries u have added?



    Regards,
    Wang

  4. #4
    Registered User
    Join Date
    Sep 2003
    Posts
    37

    Re: N80 Jad error: Compulsory attributes missing

    Hi, thanks for the replies!
    it works great on more than 40 other devices (Not only Nokia).
    It doesn't work on N-70 and N-80.

    The jad and manifest are perfectly fine, since when I directly connect to the jad it downloads the game with no problem...
    Maybe it has something to do with the http headers of the response we get from the servlet or something like that?

    Thanks again,
    Itsik

  5. #5
    Registered User
    Join Date
    Sep 2003
    Posts
    37

    Re: N80 Jad error: Compulsory attributes missing

    Ok... Found the problem.
    The servlet has put 1 empty line in the beginning of the jad file it returned... It worked on all other devices... But the N-series devices + 6680 and maybe a few others had a problem with it.

    Hope it helps anyone...
    And thanks
    Itsik

  6. #6
    Registered User
    Join Date
    Feb 2004
    Location
    Coimbatore, Tamil Nadu, India
    Posts
    1

    Post Re: N80 Jad error: Compulsory attributes missing

    That could be possibly because you have left some property as blank. Like

    ...
    MIDlet-Vendor: Vendor
    ....
    Some-Property:
    Some-Other-Property: Some-Value

    Note that Some-Property is defined but left blank. See if you have any such property that is defined but left blank.

    Hope that solves the issue

    Thanks,
    R.Prabhu
    [B]
    [COLOR=Blue]Ennai Nandraga Iraivan Padaithanan
    Thannai Nandraga Thamizh Seyyumaarey
    - Thirumoolar
    [/COLOR][/B]

  7. #7
    Registered User
    Join Date
    Apr 2007
    Posts
    29

    Re: N80 Jad error: Compulsory attributes missing

    I had the same issue and found this thread which helped me out. But I also found another interesting fact, which may help someone else.

    If you have installed a MIDlet with version 1.0.0 for instance, then upgrading to version 1.1 will NOT work and give "Compulsory attributes missing"-error message. You will have to set version 1.1.0 to make it work. So if you have started working with the "micro"-version scheme, you will have to continue using that scheme.

  8. #8
    Registered User
    Join Date
    Jan 2009
    Posts
    18

    Re: N80 Jad error: Compulsory attributes missing

    Installing an app I've been developing on the Nokia 6210 Navigator gives me this error if I include "MIDlet-Background-No-Pause: Yes" in the jad/manifest file.

  9. #9
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: N80 Jad error: Compulsory attributes missing

    Better to start a new thread, rather than tag onto a bunch of old threads.

    Shall we just work with this one?

Similar Threads

  1. getAppProperty() doesn't work with user attributes?
    By je35 in forum Mobile Java General
    Replies: 6
    Last Post: 2005-11-09, 07:59
  2. Replies: 2
    Last Post: 2005-08-04, 08:37
  3. JAD attributes on the phone screen
    By tlindstr in forum Mobile Java General
    Replies: 1
    Last Post: 2003-02-24, 10:39
  4. JAD attributes
    By tlindstr in forum Mobile Java General
    Replies: 0
    Last Post: 2003-02-21, 10:18
  5. Jad File Attributes for Nokia Phones (MIDP)
    By yogesh2002 in forum Mobile Java General
    Replies: 1
    Last Post: 2002-08-15, 15:16

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×