×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jul 2005
    Posts
    40

    Question Changes to .loc file not being compiled

    I am familiarising myself with the Carbide environment and have successfully compiled and run/installed a sample app for the S60 FP2 emulator and an actual device.

    However, if after selecting the emulator build, I then make a small change to a line in the .loc file from say-
    // LOCALISATION STRINGS
    #define qtn_appl_test "Test"

    to-
    // LOCALISATION STRINGS
    #define qtn_appl_test "Testing"

    and do either a 'rebuild' or even 'clean', when the emulator is launched, the above change is NOT seen. When I choose the ARMI build, the change IS seen when the SIS is installed on a device.

    Could someone please give me a pointer as to where I'm going wrong in the build process?

  2. #2
    Regular Contributor
    Join Date
    Mar 2005
    Location
    Mumbai
    Posts
    212

    Re: Changes to .loc file not being compiled

    Re-import the project and compile

  3. #3
    Registered User
    Join Date
    Jul 2005
    Posts
    40

    Re: Changes to .loc file not being compiled

    Thanks for suggestion, unfortunately it didn't work!! The .loc changes are still not being compiled. Despite what I said earlier the SAME problem is occurring if I choose the ARMI build instead of an emulator build. Regarding your 'import' suggestion I'm assuming you meant me to first delete the project from the 'C++ Projects' dialog with the 'do not delete contents' option and then import using the 'existing project into workspace' option (defaults to this), this import process worked without problems.
    Last edited by karlbaldwin; 2006-06-12 at 14:50. Reason: clarification

  4. #4
    Regular Contributor
    Join Date
    Mar 2005
    Location
    Mumbai
    Posts
    212

    Re: Changes to .loc file not being compiled

    If there is any option like "Clean object code" , try that.

  5. #5
    Regular Contributor
    Join Date
    Aug 2004
    Location
    Hyderabad-India
    Posts
    160

    Re: Changes to .loc file not being compiled

    I think, when you want to rebuild your project because of resource changes or whatever it is always better to do:

    abld clean <platform>
    abld reallyclean

    and after that build your project and in addition you need to to 'abld resource'

    (or)you can remove the objec files in build and release folders;


    --
    VVS.Naresh
    http://students.iiit.net/~satyanaresh/links.html
    --

  6. #6
    Registered User
    Join Date
    Jul 2005
    Posts
    40

    Re: Changes to .loc file not being compiled

    Thankyou everyone for your hints and tips. In the end I found the solution to be simple but frustrating as I'm sure thre must be better ways of managing this situation (anyone?)

    During emulator builds-
    You make changes to the .loc file
    After editing file, manually save it…
    Go to location C:\Symbian\8.0a\S60_2nd_FP2_CW\Epoc32\release\winscw\udeb\z\system\apps\<app name>
    and Delete file <appname> type ‘RSC’
    Now do ‘project/clean’
    If you go back to the ‘apps’ folder above you will see the <appname> type ‘RSC’ file has been ‘refreshed’.
    Run emulator


    You now want to switch the build to ‘ARMI’ to install on a device-
    In the ‘Build Configurations’ tab choose the ARMI build
    Do a ‘project/clean’
    The SIS will now be current with your edited .loc.
    Install to the device


    During ARMI builds-
    You make changes to the .loc file
    After editing file, MANUALLY save it…
    Now do ‘project/clean’
    The SIS will now be current with your edited .loc.
    Install to the device


    You’ve made changes in the .loc file under ARMI builds and want to switch back to the emulator. In order to see the updated (ARMI changes) version in the emulator-
    In the ‘Build Configurations’ tab choose the Emulator build
    Go to location C:\Symbian\8.0a\S60_2nd_FP2_CW\Epoc32\release\winscw\udeb\z\system\apps\<app name>
    and Delete file <appname> type ‘RSC’
    Now do ‘project/clean’
    Run emulator

    IT may not be technically correct, it's certainly not ideal, but it works- now on to the next problem....

Similar Threads

  1. problem installing sis file
    By lucidness in forum Symbian
    Replies: 8
    Last Post: 2006-04-20, 17:51
  2. File corrupted
    By MrJou in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2006-03-22, 08:26
  3. How to reformat the file?
    By ryanfunghk in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2005-03-26, 17:43
  4. How to create mbm file?
    By qt_raip in forum Symbian Tools & SDKs
    Replies: 13
    Last Post: 2004-05-12, 11:07
  5. how can I open and test a compiled help file in the nokia 9210 emulator?
    By rubyyogaswara in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2002-08-29, 05:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •