×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Registered User
    Join Date
    Apr 2006
    Posts
    8

    Multiple cookies problem

    Hi all,

    I know this issue has been raised before, but I've searched the forum and haven't found a proper solution.

    I am accessing a server from my MIDlet over HTTPS. The server is returning two cookies to me which I must send back in every subsequent request. This works fine on the Sun emulator and a Motorola handset, but on my Nokia phones I am only getting one of the cookies.

    Has this issue been resolved? Does anyone in Nokia have a workaround for it? It is a critical issue for me now as I must support multiple cookies.

    Thanks a lot to anyone who can offer some advice.
    Therese.

  2. #2
    Registered User
    Join Date
    Apr 2006
    Posts
    8

    Re: Multiple cookies problem

    Hi,

    I came across a temporary solution to this problem. By sending two requests, I manage to get the two cookies I need. However, this is obviously not an ideal solution since I'd like to keep the network traffic to a minimum.

    It would be great if someone could let me know if they have had a similar problem and managed to find a workaround. Or if someone from Nokia could confirm that this is a known issue. I haven't seen it mentioned in the list of known issues. This is a real show-stopper for me at this stage since I need to return two cookies to the server.

    I know that the server is sending me back two cookies yet when I trace all the response headers received by my application, there is only one set-cookie header.

    Thanks very much to anyone who can offer me any help.
    Cheers,
    Therese

Similar Threads

  1. multiple target patterns
    By ukelady in forum Symbian
    Replies: 5
    Last Post: 2009-07-23, 09:03
  2. About 6230 Bt Problem
    By eerkek in forum Bluetooth Technology
    Replies: 17
    Last Post: 2005-02-08, 12:33
  3. Multiple inheritance problem
    By nmnir in forum Symbian
    Replies: 6
    Last Post: 2004-10-17, 08:19
  4. Problem with playing multiple wavs
    By sopta007 in forum Symbian
    Replies: 0
    Last Post: 2003-05-14, 15:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×