×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Mar 2003
    Posts
    7

    Irda and S60 emulator

    Hai! How to configure emulator when I want to use infrared in my PC. I have internal infrared device in my laptop.

    I tried to found document "Configuring the emulator for IrDA connection to a mobile phone" (it was named elsewhere in this discussion board) from forum nokia but I didn't found it.

    - Markus

  2. #2
    Registered User
    Join Date
    Jul 2003
    Posts
    3

    Same problem

    I have the same problem.

    I did find the document "Configuring the emulator for IrDA connection to a mobile phone". This is what is given:

    The default communications settings for a Emulator are to use an infra-red capable mobile phone through the COM2 port.

    Assuming that you haven't changed the defaults through setupcomms.bat, the simplest way to get a connection is to connect an infra-red pod to the COM2 port, and point it at your mobile phone's IR port. To change to use COM1, change the irPhysicalComPort setting in Epoc32\Wins\c\System\Data\irda_wins.esk from 1 to 0.

    If you have changed the defaults, you can restore the settings by running setupcomms.bat and make the following Modem Information settings:

    Set PortName to IRCOMM::<port-number>, e.g. IRCOMM::0 for COM1.

    Set modem type to GSMBSC

    Set comms type to IRCOMM

    Other fields can be left with their default settings.

    Again, you can verify the setup by configuring an Internet connection in the Emulator's Control Panel, and opening a page in Web.


    I have a Belkin infrared serial adapter connected to the COM1
    port. I made the appropriate changes to irda_wins.esk and
    then changed the setupcomms.bat according to the above.

    After this, should I not see any change in the appearance of
    the emulator; for example, in the communications->open,
    only Bluetooth shows. I was expecting "infrared" as well.

    Or, may be the applications will run perfectly. I am yet to check that.

    Anticipating an early reply,

  3. #3
    Registered User
    Join Date
    Jul 2003
    Posts
    3

    Same problem

    I have the same problem.

    I did find the document "Configuring the emulator for IrDA connection to a mobile phone". This is what is given:

    The default communications settings for a Emulator are to use an infra-red capable mobile phone through the COM2 port.

    Assuming that you haven't changed the defaults through setupcomms.bat, the simplest way to get a connection is to connect an infra-red pod to the COM2 port, and point it at your mobile phone's IR port. To change to use COM1, change the irPhysicalComPort setting in Epoc32\Wins\c\System\Data\irda_wins.esk from 1 to 0.

    If you have changed the defaults, you can restore the settings by running setupcomms.bat and make the following Modem Information settings:

    Set PortName to IRCOMM::<port-number>, e.g. IRCOMM::0 for COM1.

    Set modem type to GSMBSC

    Set comms type to IRCOMM

    Other fields can be left with their default settings.

    Again, you can verify the setup by configuring an Internet connection in the Emulator's Control Panel, and opening a page in Web.


    I have a Belkin infrared serial adapter connected to the COM1
    port. I made the appropriate changes to irda_wins.esk and
    then changed the setupcomms.bat according to the above.

    After this, should I not see any change in the appearance of
    the emulator; for example, in the communications->open,
    only Bluetooth shows. I was expecting "infrared" as well.

    Or, may be the applications will run perfectly. I am yet to check that.

    Anticipating an early reply,

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×