×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Dec 2004
    Posts
    10

    An untill now unknown (to me at least) error message.

    I have been having problems with a java MIDlet on several phones, but one of them, a Nokia N71, shows an error message. It says:
    "Program closed*:
    Posis-408"

    And when I press OK I get a new error box saying:
    "Program closed*:
    MIDP2Runtime Under
    taker"


    * That is a tranlation for the Norwegian version which by the way is: "Progr. lukket"


    Does anyone have know what these messages mean or know how I can find out?

    --
    Regards
    Maxagaze

  2. #2
    Registered User
    Join Date
    Jul 2006
    Posts
    17

    Re: An untill now unknown (to me at least) error message.

    Hi Maxagaze,

    Have you found out anything about the message? I'm also puzzled by it. For some reason it occurs when you're retrieving a security info of a https connection with some new Nokia S60 phones (N70, N90, N71 and 3250).

    If you have the following line in your code, the result will be an error message with seemingly arbitrary Posix number following by the weird "Under taker" message, while you're closing your application. While you’re running the application there are no apparent problems, nor error messages.

    SecurityInfo info = conn.getSecurityInfo();

    With older devices you don't have such problems. Does anybody know, how you're supposed to request the security info in new S60 phones?

    Br,
    Mika

  3. #3
    Registered User
    Join Date
    Aug 2007
    Posts
    4

    Re: An untill now unknown (to me at least) error message.

    I have found exactly the same problem as described below if anyone knows anyway to fix this please post, its driving me crazy.
    Last edited by Nylkran; 2007-08-08 at 15:50.

  4. #4
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: An untill now unknown (to me at least) error message.

    Please see this known issue
    http://forum.nokia.com/document/Foru...the_MIDlet.htm

    Hartti

  5. #5
    Registered User
    Join Date
    Aug 2007
    Posts
    4

    Re: An untill now unknown (to me at least) error message.

    Hi Haarti,

    Our code does not contain that line of code or anything to do with HTTP connections, so it cannot be this issue. But thanks for the information anyway.

    Nylkran

  6. #6
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: An untill now unknown (to me at least) error message.

    Hi Nylkran! Welcome to Nokia Developer discussion Boards!!

    Please let us know which phone are you using and at which point of time does this error occour ? Are you able to find out, what event on your application leads to this error message?

    Regards
    Gopal

  7. #7
    Registered User
    Join Date
    Aug 2007
    Posts
    4

    Re: An untill now unknown (to me at least) error message.

    Hello balagopalks,

    Well it shows our companies Logo and then it crashes, the current theory is that it is some kind of issue with proguard, but downloading the newest version did nothing to fix the problem.

    Due to an NDA I cannot post any code examples, but the same code runs fine on a Sony Ericsson W900i, Sharp 902 and Samsung E900 to mention a few.

    Best Regards,
    Jose Miguel Mendez

  8. #8
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: An untill now unknown (to me at least) error message.

    Does the unobfuscated version run ok?
    What is the MIDlet doing after showing the logo?

    Hartti

  9. #9
    Registered User
    Join Date
    Aug 2007
    Posts
    4

    Re: An untill now unknown (to me at least) error message.

    Thanks for the help.

    We changed the paramters we were using with Proguard and the builds works very now.

    Nylkran

Similar Threads

  1. ERROR RCmake.exe AND rcomp.exe
    By jifik in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2005-10-31, 12:24
  2. 'Response Unknown' when downloading midlet
    By Weevil in forum Mobile Java General
    Replies: 3
    Last Post: 2004-05-30, 17:01
  3. Errors compilling and debugging Helloworld
    By doberlet in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2004-03-04, 18:08
  4. Codewarrior import .mmp error
    By serenade in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2004-02-21, 20:06

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×