×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Apr 2003
    Posts
    22

    Unhappy Performance problem with Nokia Prototype SDK 4.0 emulators.

    I have installed Nokia Prototype SDK 4.0 J2ME.
    While running applications, there are a delays.
    On Sun emulators or on S60 3rd edition emulator, the applications run smoothly.
    Can someone advice me about this problem.
    Thanks,
    Mike

  2. #2
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: Performance problem with Nokia Prototype SDK 4.0 emulators.

    Me too had the similar experience earlier with S60 emulators. But the app worked fine on real devices.
    Please dont rely with emulator fully and on its slow behaviour and strange display. Its always better to try on a real device.

    Regards
    Gopal
    Last edited by balagopalks; 2006-06-24 at 20:02.

  3. #3
    Registered User
    Join Date
    Apr 2003
    Posts
    22

    Re: Performance problem with Nokia Prototype SDK 4.0 emulators.

    Thanks Gopel.
    I am working with real devices too. But the SDK 4.0 is usefull tool in the developing process and It is working fine on my old computer.
    I have checked the Norton anti virus, the Windows Firewall, etc. But I couldn't find the reson for the poor performence of the emulators in my new computer.
    Thanks,
    Mike

  4. #4
    Super Contributor
    Join Date
    Nov 2003
    Location
    Bangalore , India
    Posts
    4,429

    Re: Performance problem with Nokia Prototype SDK 4.0 emulators.

    As the Nokia Docs say "Nokia provides two different sets of SDKs: 1) SDKs and 2) Prototype SDKs. SDKs emulate the phone behavior of Nokia devices as closely as possible, because their emulators are based on the same software as the specified Nokia devices. The emulators of a prototype SDK are based on the reference implementation of the Java™ APIs of the corresponding Platform."

    May be you shoud give a try using "S60 Platform SDKs for Symbian OS, for Java"
    available in this link http://www.forum.nokia.com/main/0,6566,034-483,00.html

    BTW, I am Gopal not Gopel ;-)

    Regards
    Gopal

  5. #5
    Registered User
    Join Date
    Apr 2003
    Posts
    22

    Re: Performance problem with Nokia Prototype SDK 4.0 emulators.

    Hi Gopal,
    Many thanks.
    You advice is great. I have already used the S60 3rd Edition SDK.. It is working smoothly.
    But I would like to find why the Prototype SDK 4.0 working smoothly, but not in my new computer. [It include Series 40, 60, 80,... emulators]
    Thanks,
    Mike

  6. #6
    Registered User
    Join Date
    Aug 2006
    Posts
    1

    Re: Performance problem with Nokia Prototype SDK 4.0 emulators.

    Hi guys,

    just wanted to drop a note that I have the same problem. On my last computer, the Nokia Prototype SDK worked very well and smoothly. But since I set up my development environment (Eclipse, EclipseMe, Sun WTK, Nokia Prototype SDK) on my new PC, the Sun Emulatores run smoothyl and the Nokia Prototype Emulators s**k, although they worked fine before. So if you have any solution or explanation for this behaviour, I would definitly be interested.

    Cheers, Greg

  7. #7
    Super Contributor
    Join Date
    Dec 2005
    Location
    Europe/Poland/Warsaw
    Posts
    1,697

    Re: Performance problem with Nokia Prototype SDK 4.0 emulators.

    hi Greg,

    could be various reason,
    for example make sure, that you are using Java SDK in 1.5.0.6 version or newer,
    regards,
    Peter

  8. #8
    Registered User
    Join Date
    Aug 2006
    Posts
    1

    Re: Performance problem with Nokia Prototype SDK 4.0 emulators.

    Hi people,

    I found a discussion on an emulator running slow on a new computer from old posts to this board. They say that some nokia emulators dont work well on a multi-processor enviroment. The problem sounds same to the one you are having.

    http://discussion.forum.nokia.com/fo...511#post110511

    Hope this helps.
    Paulus

Similar Threads

  1. Replies: 2
    Last Post: 2008-04-03, 19:02
  2. NoSuchFieldError when accessing Bluetooth using Carbide.j and Nokia Prototype SDK 4.0
    By u7clo in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2006-04-06, 00:07
  3. Nokia SDK Bluetooth service re-discovery problem, Help Me!:(
    By tomsonxu in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-11-08, 07:39
  4. Nokia 6230i SDK problem
    By Alejandro_nano in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-28, 09:30
  5. createImage on Nokia Series 40 MIDP Concept SDK Beta 0.3
    By GerardMason in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2003-09-30, 10:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×