Hi All,
I am a newbie in Location Based Services - Mobile Application Development.
As i come to know - there are few mobile those are supporting this technology till now.
In fact - supported handset are costly.

My question is:
If i am developing an application with Location API (JSR 179). And want to deploy it on a handset that supports MIDP2.0 and CLDC1.1 and some other JSRs but not JSR 179.

Can i do that by bundling my application with "jsr179.jar"? which i think could be a way.
OR - The Location API should be supported (as implemented) in Handset by the OEM.

Please Help ...