×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    364

    I Need Your Help PRJ0019 Build error

    I'm trying to build my application and it gives me the following error:


    Updating emailpop3.mmp based on Deb_S60_20_WINS
    Making a backup of the mmp file with the name 'emailpop3.mmp'.bak
    Mmp file has been updated
    WINS (emulator) build
    ------ Build started: Project: emailpop3, Configuration: Deb_S60_20_WINS Win32 ------

    Performing Pre-Build Event...
    * Current build configuration: WINS UDEB
    Converting bitmaps...
    epocroot = \Symbian\7.0s\Series60_v20\
    * C:\Symbian\7.0s\Series60_v20\\epoc32\tools\bmconv.exe /hc:\Symbian\7.0s\Series60_v20\Series60Ex\emailpop3\emailpop3\data\emailpop3.mbg C:\Symbian\7.0s\Series60_v20\Epoc32\release\wins\UDEB\emailpop3.mbm /c12D:\emailpop3\emailpop3\data\qgn_listicon_attachment.bmp /1D:\emailpop3\emailpop3\data\qgn_listicon_attachment_mask.bmp /c12D:\emailpop3\emailpop3\data\qgn_listicon_no_attachment.bmp /1D:\emailpop3\emailpop3\data\qgn_listicon_no_attachment_mask.bmp
    BMCONV version 112.
    Compiling...
    Multiple bitmap store type: File store
    Epoc file: C:\Symbian\7.0s\Series60_v20\Epoc32\release\wins\UDEB\emailpop3.mbm
    Bitmap file 1 : /c12D:\emailpop3\emailpop3\data\qgn_listicon_attachment.bmp
    Bitmap file 2 : /1D:\emailpop3\emailpop3\data\qgn_listicon_attachment_mask.bmp
    Bitmap file 3 : /c12D:\emailpop3\emailpop3\data\qgn_listicon_no_attachment.bmp
    Bitmap file 4 : /1D:\emailpop3\emailpop3\data\qgn_listicon_no_attachment_mask.bmp
    Bad command file.
    ERROR: RCMake failed: (Bitmaps): bmconv.exe failed with code 6 while converting one bitmap entry to a bitmap collection. (Reason: Unknown error)
    Project : error PRJ0019: A tool returned an error code from "Performing Pre-Build Event..."

    Build log was saved at "file://d:\emailpop3\emailpop3\Deb_S60_20_WINS\BuildLog.htm"
    emailpop3 - 1 error(s), 0 warning(s)


    ---------------------- Done ----------------------

    Build: 0 succeeded, 1 failed, 0 skipped




    The MMp file is like this:

    /////////////////////////////////////////////////////////////////////////////////////

    TARGET emailpop3.app

    TARGETTYPE app

    UID 0x100039CE 0x10005B71

    TARGETPATH \system\apps\emailpop3

    /* [+] */ START BITMAP emailpop3.mbm

    /* [+] */ HEADER

    /* [+] */ SOURCEPATH ..\data

    /* [+] */ SOURCE C12 qgn_listicon_attachment.bmp

    /* [+] */ SOURCE 1 qgn_listicon_attachment_mask.bmp

    /* [+] */ SOURCE C12 qgn_listicon_no_attachment.bmp

    /* [+] */ SOURCE 1 qgn_listicon_no_attachment_mask.bmp



    /* [+] */ END



    // [-] START BITMAP emailpop3.mbm

    // [-] HEADER

    // [-] SOURCEPATH ..\data

    // [-] SOURCE C12 qgn_listicon_attachment.bmp

    // [-] SOURCE 1 qgn_listicon_attachment_mask.bmp

    // [-] SOURCE C12 qgn_listicon_no_attachment.bmp

    // [-] SOURCE 1 qgn_listicon_no_attachment_mask.bmp



    // [-] END



    SOURCEPATH ..\data

    RESOURCE emailpop3.rss

    RESOURCE emailpop3_caption.rss



    SOURCEPATH ..\src

    SOURCE CEpop3Engine.cpp

    SOURCE CEpop3App.cpp

    SOURCE CEpop3AppUi.cpp

    SOURCE CEpop3Document.cpp

    SOURCE CEpop3Container.cpp

    SOURCE CEpop3.cpp



    USERINCLUDE ..\inc

    USERINCLUDE ..\data

    SYSTEMINCLUDE \epoc32\include

    LIBRARY imcm.lib

    LIBRARY euser.lib

    LIBRARY apparc.lib

    LIBRARY cone.lib

    LIBRARY eikcore.lib

    LIBRARY eikcoctl.lib

    LIBRARY avkon.lib

    LIBRARY commonengine.lib

    LIBRARY msgs.lib

    LIBRARY mtur.lib

    AIF emailpop3.aif ..\aif emailpop3aif.rss c12 emailpop3_icon.bmp emailpop3_icon_mask.bmp emailpop3_lst.bmp emailpop3_lst_mask.bmp

    LANG SC

    //////////////////////////////////////////////////////////////////

    How I can solve this problem?

  2. #2
    Regular Contributor
    Join Date
    Aug 2004
    Posts
    94

    Re: I Need Your Help PRJ0019 Build error

    Try to move the project to the same drive as the SDK. Also make sure that the entire project path doesn't contain any spaces.

    S.

  3. #3
    Regular Contributor
    Join Date
    Aug 2005
    Posts
    364

    Re: I Need Your Help PRJ0019 Build error

    Thanks alot , but I want to ask question , Is it required (mandatory) to create any application in the future inside the SDK Directory?

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,568

    Re: I Need Your Help PRJ0019 Build error

    Quote Originally Posted by mubx2000
    Thanks alot , but I want to ask question , Is it required (mandatory) to create any application in the future inside the SDK Directory?
    No. What is mandatory is that all projects and the SDK has to reside on the same drive. Most Symbian tools take colon as sequence separator, that is why drive letters can not be used.

  5. #5
    Regular Contributor
    Join Date
    Jul 2006
    Posts
    145

    Re: I Need Your Help PRJ0019 Build error

    Hi!
    I have the same problem, but my project directory is on the same drive as the SDK and I have no space in the path of my project.
    Please how can I solve my problem?
    Thanks.

Similar Threads

  1. XMl Parser Implementation for Symbian
    By ittiam in forum Symbian
    Replies: 26
    Last Post: 2009-09-16, 05:26
  2. problem with the XML Parser SyExpat
    By Vitaly_iva in forum Symbian
    Replies: 2
    Last Post: 2006-06-05, 11:09
  3. help !! about SIP errors
    By wgarnett in forum Symbian
    Replies: 3
    Last Post: 2006-05-17, 05:30
  4. S80 Platform SDK and Visual Studio .NET Linking Error
    By jayantjain in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2005-10-07, 22:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •