I m working around on sending a video MMS to a mobile phone. Actually I have been successfully send a MMS image to a mobile phone. Below is the smil that i used to compose mms for image and video:

-- SMIL for image
<smil>
<head>
<layout>
<root-layout width="160" height="140"/>
<region id="Image" width="100%" height="100%" left="0" top="0"/>
<region id="Text" width="100%" height="100%" left="0" top="0"/>
</layout>
</head>
<body>
<par dur="5000ms">
<img src="118280.SOKEAN2.2006.04.03-17_04_46.jpg" region="Image"/>
</par>
<par dur="5000ms">
<text src="118280.SOKEAN2.2006.04.03-17_04_46.txt" region="Text"/>
</par>
</body>
</smil>


-- SMIL for video
<smil>
<head>
<layout>
<root-layout width="160" height="140"/>
<region id="Video" width="100%" height="100%" left="0" top="0"/>
<region id="Text" width="100%" height="100%" left="0" top="0"/>
</layout>
</head>
<body>
<par dur="10000ms">
<video src="60162232833.NEW_INAVIGATE.2006.06.16-09_43_07.3gp" region="Video"/>
</par>
<par dur="5000ms">
<text src="60162232833.NEW_INAVIGATE.2006.06.16-09_43_07.txt" region="Text"/>
</par>
</body>
</smil>


** all the image and video file is inside the same directory as the smil.

Now, my problem is I manage to compose the mms, (that can be play in Nokia Multimedia Player) but when i try to send it composed mms to a mobile phone, (I m using nokia 6680) I m able to read the image MMS correctly but not the video MMS.

When I try and open the video MMS, the mobile phone prompt me something like [Select 'Objects' in options menu to view the attached objects]. And when I click on the options menu to play presentation, I get a white screen and some text on the screen. Can anyone tell me where i get wrong. And how can I send a mms with video