×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    Aug 2005
    Location
    Venice, California
    Posts
    67

    Question ProGuard Installation

    Hello,

    I am having trouble installing and using the ProGuard obfuscator with eclipseme.
    I followed all of the installation instructions I can find. They discuss eclipse preference settings, but not installation of ProGuard (i.e. http://eclipseme.org/docs/configuring.html).

    Would someone please post instructions or a link to instructions on installation and configuration of ProGuard v3.6 or v3.7beta?

    My current specific error is:
    mymidlet -> J2ME -> Create Obfuscated Package...
    Could not find jar tool executable
    The jar tool requires a full JDK installation.
    Specify a full JDK installation in the Java preferences

    I am using JDK v1.5.0_06.
    I do not know where/how to specify the JDK in the Java preferences, presumably: eclipseme -> window -> Preferences... -> Java ??
    I do specify the same version JRE in this location.

    - Sincerely, David Manpearl dmanpearl_at_imatte_dot_com

    P.S. As this is likely a common question, I realize that it may have already been covered in this forum. I tried various keyword searches with unsatisfactory success. Links to threads I missed are welcome in your response.

  2. #2
    Super Contributor
    Join Date
    Dec 2005
    Location
    Europe/Poland/Warsaw
    Posts
    1,697

    Re: ProGuard Installation

    hi David,

    have you tried that step:
    http://eclipseme.org/docs/configuring.html#step5
    ?
    it seems you need to perform proguard setup first before performing steps in Eclipse,
    it seems as simple as unzipping progaurd distribution file into some location and additn to classpath (project path/tools path),
    e.g.:
    Uncompress the proguard.jar file from the lib directory of the ProGuard installation to the bin directory of your J2ME Wireless Toolkit installation.
    http://java.sun.com/j2me/docs/wtk2.2...eveloping.html

    by the way: with tool like MobilityPack for NetBeans I didn't have to do any steps except of adding nokia sdks into IDE configuration, other thigns are already setup for easy start (that is proguard is shipped with ide and built into default configuration for j2me projects),

    regards,
    peter

  3. #3
    Regular Contributor
    Join Date
    Aug 2005
    Location
    Venice, California
    Posts
    67

    Re: ProGuard Installation

    Peter,
    Thank you for your advice.
    I was missing the installation step you predicted:

    http://java.sun.com/j2me/docs/wtk2.2...eveloping.html
    2.4 Using an Obfuscator
    3. Uncompress the proguard.jar file from the lib directory of the ProGuard installation to the bin directory of your J2ME Wireless Toolkit installation

    I uncompressed to C:/WTK23/bin. I also tried C:\Program Files\Java\jdk1.5.0_06\bin (Some people say to always use JDK v1.4.2 instead of 1.5. Does anyone know why?).

    Anyhow, I still get the same error:

    Could not find jar tool executable
    The jar tool requires a full JDK installation.
    Specify a full JDK installation in the Java preferences

    - Thanks again, David Manpearl dmanpearl_at_imatte_dot_com

  4. #4
    Registered User
    Join Date
    Jul 2005
    Posts
    6

    Re: ProGuard Installation

    I know this might be a late comment.

    I had the same problem with proguard and eclipse. I found your post while searching.

    I added the JDK to the Java configuration instead of the JRE. Things worked fine.

    Regards

  5. #5
    Registered User
    Join Date
    Dec 2005
    Posts
    30

    Re: ProGuard Installation

    I have the same problem. I have used the obfuscator before and it was working very well. The only change I made is that I used JDK 6 instead of JDK 5. Does this make a problem. I tried to install the latest version (Beta) of proguard. The same problem still arise. However, when I use proguard standalone it works very fine.
    Wait a minute I will try the last method ....
    Yes! It worked! I added the jdk bin directory to the system path

    --
    Regards,
    No one

  6. #6
    Regular Contributor
    Join Date
    Oct 2006
    Posts
    157

    Re: ProGuard Installation

    I had the same error and got it working when I added Proguard's lib path and the java jdk bin path to the system $path environment variable.

    Now I get an error when I try to start the app on the phone. Anyone got an idea why?

Similar Threads

  1. Problem with Proguard Obfuscator
    By anrikun in forum Mobile Java General
    Replies: 3
    Last Post: 2007-08-01, 09:36
  2. Installation Problem on the Nokia 6600
    By ManishPatil in forum Symbian
    Replies: 1
    Last Post: 2005-02-02, 09:51
  3. D211 installation problems with XP pro
    By espengr in forum Multimodecards
    Replies: 3
    Last Post: 2004-02-05, 10:25
  4. NDS 2.0 Installation Problem
    By morozov in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2003-11-12, 22:51
  5. 6600 program installation problems
    By mparkkon in forum Symbian
    Replies: 0
    Last Post: 2003-10-29, 05:54

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×