×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Nov 2004
    Posts
    44

    Unhappy Problem about plugin!

    I have a well-run plugin application example, including several dlls(some parent plugins and some child plugins).

    I imported a child plugin mmp in codewarrior, and then made it. When i launch the S60 emulator, i found the plugin which i made just now was missing(that is to say, befor being made the plugin is visible). Then i tried another child plugin in the example, the same situation occured.

    why? and what can i do to resume the plugin in the applicaion?

    Thanks for your help!

  2. #2
    Regular Contributor
    Join Date
    Jul 2005
    Posts
    185

    Re: Problem about plugin!

    Most likely your talking about ECom plugins? And by missing you mean that the plugin isn't found? Check the UID's, i guess you're using the same UID for several plugins.

  3. #3
    Registered User
    Join Date
    Nov 2004
    Posts
    44

    Re: Problem about plugin!

    Yes, ECom plugins.
    The plugin generated the corresponding dll successfully, but the plugin GUI is unvisible in the application now

    Quote Originally Posted by pkosonen
    Most likely your talking about ECom plugins? And by missing you mean that the plugin isn't found? Check the UID's, i guess you're using the same UID for several plugins.

  4. #4
    Registered User
    Join Date
    Nov 2004
    Posts
    44

    Re: Problem about plugin!

    Nobody knows this problem here?

    This problem broke my head...

  5. #5
    Regular Contributor
    Join Date
    Jul 2005
    Posts
    185

    Re: Problem about plugin!

    I guess nobody understands what you mean by plugin GUI, atleast I don't. Have you changed the UIDs? See also the following (taken from FN document S60 Platform: ECom Plug-In Architecture):

    Note: If the UID of plugin DLL is changed (and correspondingly the name of rss
    file is changed), the ECOM framework may not find the plugin with new UID.
    It may be necessary to delete following files from your SDK:
    ECom.ROM.dat
    ECom.idx
    They are in development environment folder
    \Series60_v20\Epoc32\wins\c\system\data\Plugins
    And in 3rd edition the files ECom.ROM.Z.dat and ECom.idx are located in:
    \S60_3rd\Epoc32\winscw\c\private\10009D8F folder
    There may occur similar problems on real devices so avoid changing the UIDs if possible.

  6. #6
    Registered User
    Join Date
    Nov 2004
    Posts
    44

    Re: Problem about plugin!

    Actually i don´t change the UID or any other files at all, what i only do is to import the plugin MMP file in Codewarrior, then make it. This resulted the plugin was unvisible from the application.
    What makes me confused is that the plugin dll is recreated, but it seems that the application can´t recognize the plugin dll any more

Similar Threads

  1. MMF Controller plugin
    By cherem in forum Symbian Media (Closed)
    Replies: 24
    Last Post: 2007-12-06, 00:36
  2. SIP ECOM plugin not working on Nokia 6600?
    By marcel_kok555 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2006-01-25, 10:58
  3. About 6230 Bt Problem
    By eerkek in forum Bluetooth Technology
    Replies: 17
    Last Post: 2005-02-08, 12:33
  4. SIP plugin problem
    By umesh4u in forum Nokia M2M
    Replies: 0
    Last Post: 2004-11-15, 12:15
  5. Ethernet plugin for Series 60 and Windows NT 4
    By jykkejee in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2004-09-23, 10:48

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×