×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jul 2006
    Location
    Wieliczka, Poland
    Posts
    64

    Question Carbide.c++ post build

    When I add a 'post build' expression (ex. dir or move) in project window: properties/build steps/post-build steps->command, I've got the following error:
    ...
    make --no-print-directory post-build
    src/CGetNetworkInfo.d:1: *** missing separator. Stop.
    make: *** [C:/Symbian/9.1/S60_3rd/epoc32/release/WINSCW/UDEB/test0.exe] Error 2
    make: Target `all' not remade because of errors.
    Build complete for project test0


    this error is generated from makefile file:


    all: secondary-outputs C:/Symbian/9.1/S60_3rd/epoc32/release/WINSCW/UDEB/test0.exe $(SIS_OBJS)

    # Tool invocations
    C:/Symbian/9.1/S60_3rd/epoc32/release/WINSCW/UDEB/test0.exe: $(OBJS) $(USER_OBJS)
    @echo 'Building target: $@'
    @echo 'Invoking: WINSCW C/C++ Linker'
    @echo mwldsym2.exe -sym full -subsystem windows -msgstyle parseable -nowraplines -nodefaultlibs -stdlib -noimplib -m="?_E32Bootstrap@@YGXXZ" -L"${EPOCROOT}epoc32\release\winscw\udeb" -o "$@" -search $(OBJS) $(USER_OBJS) $(LIBS)
    @mwldsym2.exe -sym full -subsystem windows -msgstyle parseable -nowraplines -nodefaultlibs -stdlib -noimplib -m="?_E32Bootstrap@@YGXXZ" -L"${EPOCROOT}epoc32\release\winscw\udeb" -o "$@" -search $(OBJS) $(USER_OBJS) $(LIBS)
    @echo 'Finished building target: $@'
    @echo ' '
    $(MAKE) --no-print-directory post-build

    # Other Targets
    clean:
    -$(RM) $(AIF_OBJS_FOR_DEL)$(LINKER_OUTPUT_TYPES_OUTPUTS_FOR_DEL)$(OBJS_FOR_DEL)$(MIF_OBJS_FOR_DEL)$(RSC_OBJS_FOR_DEL)$(DEF_OBJS_FOR_DEL)$(DEPS_FOR_DEL)$(MBM_OBJS_FOR_DEL) C:\Symbian\9.1\S60_3rd\epoc32\release\WINSCW\UDEB\test0.exe
    -@echo ' '

    post-build:
    -dir
    -@echo ' '


    How to add a post-build action in Carbide.c++

  2. #2
    Registered User
    Join Date
    Jun 2006
    Posts
    20

    Re: Carbide.c++ post build

    Same here! Build fails with the following error message:

    Code:
    make --no-print-directory post-build
    src/Main.d:1: *** missing separator.  Stop.
    make: *** [C:/Programme/Symbian/8.1a/S60_2nd_FP3/epoc32/release/WINSCW/UDEB/Z/system/apps/PbkDataSupplier/PbkDataSupplier.dll] Error 2
    make: Target `main-build' not remade because of errors.
    Build complete for project PbkDataSupplier
    Interestingly, Main.d doesn't fail if used during normal build, it fails only for post-build. Is there any workaround available? Or does anybody know if this bug is fixed in Carbide 1.1?
    Last edited by pandreas81; 2006-09-25 at 10:21.

  3. #3
    Nokia Developer Expert
    Join Date
    Oct 2004
    Location
    Austin, TX USA
    Posts
    271

    Re: Carbide.c++ post build

    Looks like this is a bug with v1.0. I get the same behavior with that version and it works properly in v1.1.

    Regards,

    Matt P.

Similar Threads

  1. Latest Carbide.vs and problems with ARMI build
    By mhakkara in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2006-04-05, 10:17
  2. Build problem
    By kirangullapalli in forum Symbian
    Replies: 1
    Last Post: 2004-10-19, 11:07
  3. Build problem
    By kirangullapalli in forum Symbian
    Replies: 0
    Last Post: 2004-10-09, 14:24
  4. ARMI Build for fep fails
    By Blkangel in forum Symbian
    Replies: 0
    Last Post: 2004-01-27, 09:50
  5. armi build not working
    By lemody in forum Symbian
    Replies: 0
    Last Post: 2003-06-14, 15:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×