×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Jul 2006
    Posts
    21

    unable to build in carbide

    hi all,

    I have installed Carbide C++.
    m trying to build an application. When i build it using " build project" , it does not give any error, but a warning is thrown: CTags not installed or not in path

    The target file is not created at all...

    Could any help me in this regard... wat does this CTags mean

    Thanx in Advance...

  2. #2
    Regular Contributor
    Join Date
    Jun 2006
    Posts
    230

    Re: unable to build in carbide

    I think u don't have set the path of ur pkg file. It may giv this warning becoz of that

    Symbee

  3. #3
    Registered User
    Join Date
    Jul 2006
    Posts
    21

    Re: unable to build in carbide

    Where do i need to set the pkg file path?

  4. #4
    Regular Contributor
    Join Date
    Jun 2006
    Posts
    230

    Re: unable to build in carbide

    In pkg file itself,there is some path given like this(for 2nd edition)
    \\...\\Epoc32\release\thumb\urel\dummy.app" -"!:\system\apps\dummy\dummy.app"
    just edit \\..\\ by ur original path i.e. in whichever drive u have installed ur sdk..for me it is like this
    "C:\Symbian\7.0s\Series60_v21_CW\Epoc32\release\thumb\urel\dummy.app" -"!:\system\apps\dummy\dummy.app"

    Symbee

  5. #5
    Registered User
    Join Date
    Jul 2006
    Posts
    21

    Re: unable to build in carbide

    Hi Symbee,

    m trying to create build for the Emulator.
    The target file is not getting created... Also it does not show any error...

    The Console Window says:
    "No tool found that can build the extension specified with the build arrtifact name all'
    Build complete for project <project_name>


    My research Shows that the message" No tool found that can build ...... " Comes due to the the long I/p Path (http://www.nishantkumar.net/mobilega...orkaround.html )
    So i have mapped the SDK path, to shorten it...
    But Still the problem exists :-(

  6. #6
    Regular Contributor
    Join Date
    Jun 2006
    Posts
    230

    Re: unable to build in carbide

    I think u have done mistake anywhere! have u checked that ur app file n other files given in .pkg file are in the same path's folder ?

    I m not much clear about ur problem..what ur Problem window says?

    Symbee

  7. #7
    Registered User
    Join Date
    Jul 2006
    Posts
    21

    Re: unable to build in carbide

    As i said there r no errors in d problem Window.
    It shows a warning ,"CTags not installed or not in the path".

    I think, since i m not creating the SIS file rit now, the pkg wil not create the problem.

    The Reason is Somethng Else...

  8. #8
    Registered User
    Join Date
    Jun 2005
    Posts
    34

    Re: unable to build in carbide

    Hi,

    CTags is just a tool for indexing C code, it has nothing to do with your build success.

    It's hard to tell what your problem is, but please check the following things:

    1.) Make sure your project path name contains NO SPACES, e.g. "c:\my documents\john doe\cool app\" is NOT acceptaptable, since many Symbian tools cannot cope with spaces in path names.

    2.) If your build fails for an unreported reason, check the console output: the error-parsers in carbide aren't perfect (especially with device builds), so a little manual assistance is still required at times.

    Good luck,
    -- Mikko

  9. #9
    Registered User
    Join Date
    Jul 2006
    Location
    ahmedabd
    Posts
    43

    Re: unable to build in carbide

    check your Application file and also check warning message file.i hope definate u have solve this problem.

  10. #10
    Registered User
    Join Date
    Jul 2006
    Posts
    21

    Re: unable to build in carbide

    Thanx for the responce :-)

    my prjt path name contains no spaces...

    Actually the target file of My project is:
    TARGET project_name.bbp
    TARGETTYPE dll


    When i build my project,the Console Window says:
    "No tool found that can build the extension specified with the build arrtifact name all'
    Build complete for project <project_name>



    i found a piece of info frm the FORUM, whch says:
    The problem is that the include paths for the WINSCW compiler need to be generarted from environement variables and can't becuase Carbide does not create them. Currently to workaround the problem you can install CW or Carbide.vs. There is a utility in these installations called 'evn_update.exe' that can set these variables for you dynamically.

    but i do not know how to enable the Utility 'evn_update.exe' so as to set the variabels...

    can ne1 help :-(

  11. #11
    Regular Contributor
    Join Date
    Mar 2006
    Posts
    280

    Re: unable to build in carbide

    Hello;
    Just had the same thing. I got round this by changing the target extension to .dll (either in the "artifact extension build setting, or the mmp) and renaming it in a post build step.
    copy /Y ${EPOC32_RELEASE_ROOT}\\${TARGET_DIR}\\sqm.dll* ${EPOC32_RELEASE_ROOT}\\${TARGET_DIR}\\sqm.mfm*
    This should rename the dll and the map.
    This also requires you to set TARGET_DIR to GCCE\UREL, or some other config in the environment.
    Not sure if this is the best way. It would be good to be able to set mfm or bbp to valid targets, but haven't found a way to do this yet.

  12. #12
    Registered User
    Join Date
    Oct 2006
    Location
    Poland
    Posts
    45

    Re: unable to build in carbide

    Just had the same error, on creating project (and its filesystem) from scratch in Carbide.

    The error message:
    'No tool found that can build the extension specified with the build arrtifact name all'
    Build complete for project <project_name>


    Solved by going to Project properties, Build Settings Tab, and filling the Arfifact extension field with exe (for a console project).

    Hope this helps someone sometime

Similar Threads

  1. Build hangs in Carbide c++ Express
    By towebi in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 15
    Last Post: 2007-08-06, 15:10
  2. Build error on carbide c++ express
    By yuichi.sakamaki in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2007-06-25, 12:39
  3. Build does not succeed in Carbide
    By junnu76 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 5
    Last Post: 2006-04-21, 13:23
  4. Carbide C++ Build Configs Window Corrupt
    By paulaamills in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2006-03-14, 11:51
  5. carbide: batch build options
    By juliaf in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-03-09, 15:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×