×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jul 2006
    Location
    Legnica, Poland
    Posts
    12

    Where is SDK for S60 1st Edition?

    Where from can I download SDK for S60 1st Edition (MIDP1, NokiaUI, for example N-Gage)? On nokia.forum.com I read:

    =================

    Available SDK packages
    - SDK for 3rd Edition
    - SDK for 2nd Edition, FP 3
    - SDK for 2nd Edition, FP 2 - Japanese
    - SDK for 2nd Edition, FP 2 - Chinese
    - SDK for 2nd Edition, FP 2
    - SDK for 2nd Edition, FP 1
    - SDK for 2nd Edition, FP 1 - Chinese
    - SDK for 2nd Edition - Chinese
    - SDK for 1st Edition (Series 60 Platform 1.0)

    Download the package by clicking and choosing from the drop-down menu on the right.

    =================

    However in drop-down menu doesn't exist SDK for 1st Edition for J2ME (only for SymbianOS).

    In description of model N-Gage I can't find "Recommended SDK(s)". It doesn't exist. In SDK for 3rd ans 2nd Edition doesn't exist NokiaUI library. I need it...

    MDW

  2. #2
    Super Contributor
    Join Date
    Dec 2005
    Location
    Europe/Poland/Warsaw
    Posts
    1,697

    Re: Where is SDK for S60 1st Edition?

    hi,

    Nokia UI is supported - only some methods are marked as deprecated in most recent docs,
    have you tried to run yoru midlet with Nokia UI used in any of above emulators?
    e.g.:
    S60 3rd Edition SDK:
    The S60 SDK supports the following Java APIs:
    * Nokia UI API 1.1
    regards,
    Peter

  3. #3
    Registered User
    Join Date
    Jul 2006
    Location
    Legnica, Poland
    Posts
    12

    Re: Where is SDK for S60 1st Edition?

    Thank you for answer!

    Quote Originally Posted by peterblazejewicz
    Nokia UI is supported - only some methods are marked as deprecated in most recent docs,
    have you tried to run yoru midlet with Nokia UI used in any of above emulators?
    e.g.:
    S60 3rd Edition SDK:
    Emulator of S60 3rd Edition SDK supports NokiaUI. My program works on this emulator. I thought that library from this SDK (C:\Nokia\Devices\S60_3rd_MIDP_SDK\lib\hmidps60v30.jar) doesn't support NokiaUI. I was sure, I tried... I check now and... it works. I don't know what happened earlier. On S60 2nd Edition doesn't work however on S60 3rd Edition works. Thank you.

    I have next question about emulator S60 3rd Edition. The emulator starts long time.

    Emulator progress:

    Load user preferences
    Parse command
    Creaete Jad file
    Resolve application name
    Create Jar file
    Connect to Agent (long time)
    Request free ports
    VM starting...
    Done

    I have to wait long time in "Connect to Agent". Can I start faster game on this emulator?

    MDW
    Last edited by MDWPPC; 2006-07-31 at 19:12.

  4. #4
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: Where is SDK for S60 1st Edition?

    If you want the N-Gage SDK you could download the "Series 60 MIDP SDK 1.2.1 for Symbian..." from the drop down menu. The naming is not exactly clear and also the names are too long for the drop down menu...

    Hartti

  5. #5
    Super Contributor
    Join Date
    Dec 2005
    Location
    Europe/Poland/Warsaw
    Posts
    1,697

    Re: Where is SDK for S60 1st Edition?

    hi,

    I have next question about emulator S60 3rd Edition. The emulator starts long time.

    Emulator progress:

    Load user preferences
    Parse command
    Creaete Jad file
    Resolve application name
    Create Jar file
    Connect to Agent (long time)
    Request free ports
    VM starting...
    Done
    that's simple, never close emulator after first start, if your IDE supports that (e.g. NetBeans Mobility has that feature), simply exit midlet on emulator just like on real phone, it will close connection between emulator and IDE leaving emulator in "ready" state,
    so during next round of test/debug if will load midlet faster (much faster) because main debugging/testing emulator core engine is already setup and listening,
    the same rule for S40 3rd ED FP1 emulator and NetBeans MobilityPack (manually killing running thread in IDE can be required though)

    regards,
    Peter

  6. #6
    Registered User
    Join Date
    Feb 2007
    Posts
    17

    Re: Where is SDK for S60 1st Edition?

    I integrated s 60 sdk with netbeans. But the propblem is when i create a new project specifying the platform as s60 and run it, Enulator progress shows connect to agent and never disappears...and emulator opens up saying Please wait running on port 110011.. and does nothing ..any somution?

Similar Threads

  1. Problem with the downloaded 3rd Edition SDK
    By razas in forum Symbian Tools & SDKs
    Replies: 9
    Last Post: 2010-04-24, 20:58
  2. smsu.lib missing in S60 3rd edition sdk
    By bounaux in forum Tools and SDK Feedback (Closed)
    Replies: 1
    Last Post: 2006-09-08, 11:55
  3. Carbide.c++ Express V1.0 and SDK for 1st Edition
    By SergeyNik in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-04-28, 11:17
  4. Carbide.c++ Express can not use SDK for 3rd Edition (Beta)
    By SABER in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2006-02-25, 05:09
  5. OpenGL ES Support in S60 3rd Edition Beta SDK
    By choefele in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2005-12-14, 06:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×