×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Unhappy Code Warrior Problem!!!

    Hello friends,
    I have created my own Application using CW for S60-3rd.

    1)CW->File->New->Symbian Project Wizard-> C:\Test->
    2)Vendor->Nokia->s60 S60_3rd_MR
    3)Series60->APP->Generate Platform......(Checked)
    4)Platform Selection(Blank)

    Now in my application i want to use RFile.
    I implemeted RFile successfully.

    Now i am able to compile and make it from Command Line.
    -bldmake bldfiles
    -abld build winscw udeb
    -EPOC


    Uptill now everything worked fine for me.
    I can see my changes in Emulator very well.

    Now i want to debug my project.
    But it gives me Linking error regarding RFile and it's family members.

    I was getting same error in 2nd Edition also but at that time i used to
    abld build vc6 and then i used to call my project from c:\Symbian\s602nd...\BUILD\..
    I was able to debug like this in 2nd edition using VC++ IDE.

    But now as far as Code Warrior is concerned, i m very new to it.
    So i don't find any solution. It's frustrating.
    What are the changes i need to do to debug my Project in CW?

    Hope for yr reply.
    Thanks.
    Kiran.

  2. #2
    Super Contributor
    Join Date
    Nov 2005
    Location
    London
    Posts
    584

    Re: Code Warrior Problem!!!

    You need to link against efsrv.lib (the library for filesystem access).

    You can do this through the CodeWarrior GUI (add the library to the list of those you already link against). Or you can add it to the MMP file and regenerate the codewarrior project.

Similar Threads

  1. Replies: 2
    Last Post: 2007-10-05, 20:40
  2. Link errors when trying to Display bitmap
    By Bkc82 in forum Symbian Media (Closed)
    Replies: 1
    Last Post: 2006-01-16, 22:46
  3. How to handle a response with HTTP status code 100 (Continue)?
    By danieldkim in forum Mobile Java General
    Replies: 5
    Last Post: 2004-01-19, 10:54
  4. Replies: 0
    Last Post: 2003-09-26, 15:07

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×