×

Discussion Board

Results 1 to 15 of 15
  1. #1
    Registered User
    Join Date
    Dec 2005
    Location
    Finland
    Posts
    109

    6280 video & sound

    Hi,

    Just got my long waited 6280. And right away encoutered some problems with it =).
    I have program which displayes video from camera on canvas. In Nokia Series60 devices I use DirectGraphics to access video displayed on screen. But in Series40 3rd Edition my DirectGraphics.getPixels() returns RGB-value of R=255,G=255,B=255, but still I can see video displayed on screen. As if it couldn't access video on-screen instead it takes color from canvas behind video.

    So I would need some help if there's anyone who uses samekind of method, or have succesfully used DirectGraphics and video?

    My other problem is with getSnapshot(null) method. In my application it allways plays shutter sound when called. Can this be disabled with some function, I really don't need this sound, it only confuses user. I have tried to get VolumeControl from my Player, but because it's videoplayer it doesen't have VolumeControl.

    Help/ideas needed =)

    [EDIT]
    Now I can confirm that DirectGraphics works but it takes color behind of video. If I draw red polygon size of video to canvas, video is displayed front of it but DirectGraphics returns 255,0,0. So DirectGraphics itself is working, but it is'nt aware of video. Also in S60 i can draw polygon on video, but in Series40 video is on top of polygon. So I am using wrong graphics context, or is this just a one feature of Series40?
    [/EDIT]

    Jascco
    Last edited by jascco; 2006-08-09 at 13:50.

  2. #2
    Super Contributor
    Join Date
    Dec 2005
    Location
    Europe/Poland/Warsaw
    Posts
    1,697

    Re: 6280 video & sound

    hi Jascco,

    as to overlay/graphic context color we have such discussion somewhere (overlay over video canvas) and its within docs that implementation can very accross devices if something can be drawn over canvas/video player or not,
    http://discussion.forum.nokia.com/fo...hlight=overlay

    as to second try first if that devcie has such settings (in native OS) like "camera shutter sounds" and play with them, that is probably outside of java api I think,

    regards,
    Peter

  3. #3
    Registered User
    Join Date
    Dec 2005
    Location
    Finland
    Posts
    109

    Re: 6280 video & sound

    Thanks Peter for advices,

    I have seen those threads, but there were not helpful. As they didn't discuss about getting pixels from video stream via DirectGraphics API. But know I think if you can't overlay something over video you can't use getPixels method. That's sad because in Series60 I can get multiple frames in second if I use DirectGraphics, now in Series40 I use getSnapshot() and it can produce image per second (I do some heavy imageprocessing).

    As to my second questions, I did try to set native camera applications sound to off. But still sound was played in my Java application.

    update: Even if I set device to silent, sound is still played when I call getSnapshot() -> if this is feature is a bad one

    Jascco
    Last edited by jascco; 2006-08-10 at 08:43.

  4. #4
    Super Contributor
    Join Date
    Dec 2005
    Location
    Europe/Poland/Warsaw
    Posts
    1,697

    Re: 6280 video & sound

    Hi Jascco,

    the second issue is a question to Nokia dev-team members,
    what you have described is like description for S60 devices:
    #
    Camera alarm sounds
    A single alarm tone is played at the beginning of a video recording. When a video snapshot (a photograph) is taken, a camera shutter sound is played.
    (from Java Developers Library doc),
    however I can't find reference about relation of that sounds with system audio settings,
    regards,
    Peter

  5. #5
    Registered User
    Join Date
    Dec 2005
    Location
    Finland
    Posts
    109

    Re: 6280 video & sound

    Hi,

    I adapted to not to use DirectGraphics as I didn't find any way to get it work, hopefullu Nokia sorts this out baecause it's great feature in Series60.

    What comes to that shutter sound, I got nothing to it. I even tried to play some sound over it but still it was played. As you mentioned that line in Developers Library, I checked that and it says in S60 3rd Edition not in Series40 3rd Edition, this is weird because in my E70 shutter sound is not played but in 6280 it's played. Is there just a missing line or it hasn't mentioned in this version of Library. I think there's also some law issues in it, so that you can't take photos without target notificies it.

    Ok, I think I go with sound for now, because my 6280 went blind in battery changer, I have to return it to dealer. I get back to this issue as I get new.

    Jascco

  6. #6
    Regular Contributor
    Join Date
    Oct 2003
    Posts
    62

    Re: 6280 video & sound

    Does it help to turn off Warning Tones in your Profile?
    For my app too it is unacceptable to hear shutter sound,
    so I'd be interested in any workaround.

    Peter Meijer


    The vOICe for Mobile Camera Phone and PDA
    http://www.seeingwithsound.com/midlet.htm

  7. #7
    Registered User
    Join Date
    Dec 2005
    Location
    Finland
    Posts
    109

    Re: 6280 video & sound

    My 6280 went back to reseller, but I tested your suggestion in my E70. There is no shutter sound in any case but I run to interesting effect. I play sound in following way, this is my manual way to do shutter sound when I want it.

    Code:
    InputStream is = getClass().getResourceAsStream("/shutter.amr");
    Player p = Manager.createPlayer(is, "audio/amr");
    p.start();
    When warning sounds are OFF then nothing is played. When ON sound is played.
    So I think you are on right track, I will test it with 6280 as if I will get it back.

    jascco

  8. #8
    Regular Contributor
    Join Date
    Oct 2003
    Posts
    62

    Re: 6280 video & sound

    Thanks jascco, I find the same with my app on a Nokia 6680
    (which fortunately does not have shutter sounds), that is,

    > When warning sounds are OFF then nothing is played. When ON sound is played.

    but that would effectively break my app which must give
    its own sound output while shutter sounds must be disabled.
    Shutter sounds may help with privacy concerns, but they
    are a disaster for those who have a need for continuous
    camera feedback through sound, and don't want a shutter
    sound every second or so.

    Peter Meijer


    The vOICe for Mobile Camera Phone and PDA
    http://www.seeingwithsound.com/midlet.htm

  9. #9
    Regular Contributor
    Join Date
    Oct 2003
    Posts
    62

    Re: 6280 video & sound

    An update about audio problems with the Nokia 6280: I recently
    received two independent problem reports from users running my
    Java MIDlet, getting "audio device not available" messages as
    a result of DEVICE_UNAVAILABLE events on the audio device of
    the Nokia 6280.

    Is this a known Nokia 6280 firmware bug? The very same MIDlet
    runs fine on Series 60 phones.

    Does the Nokia 6280 have multichannel audio limitations that
    do not exist on the Series 60 phones? Other limitations?

    Thanks,

    Peter Meijer


    The vOICe for Mobile Camera Phone and PDA
    http://www.seeingwithsound.com/midlet.htm

  10. #10
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: 6280 video & sound

    If you mean vOICe midlet, that seems to be running fine on 6280. Although it is pretty loud :-)

    The support for various audio formats varies from phone to phone, for more info, see this doc
    http://www.forum.nokia.com/info/sw.n..._0_en.pdf.html

    Hartti

  11. #11
    Regular Contributor
    Join Date
    Oct 2003
    Posts
    62

    Re: 6280 video & sound

    Thank you, hartti! It may once again be a firmware version
    issue that determines whether it works on a given phone type
    or not. I had almost discarded the 6280 as a compatible phone
    (despite compatible specifications), but now I may need to
    rephrase it to a "may not work" clause.

    Peter Meijer

  12. #12
    Super Contributor
    Join Date
    Apr 2003
    Location
    USA, CA
    Posts
    7,191

    Re: 6280 video & sound

    When did the people experience the problem? Did they do something before the failure? Did they change some settings in the app?

    Hartti

  13. #13
    Regular Contributor
    Join Date
    Oct 2003
    Posts
    62

    Re: 6280 video & sound

    > When did the people experience the problem? Did they do something before the failure? Did they change some settings in the app?

    As far as I know they ran into the problem right away after
    giving the MIDlet permission to use the camera, and running
    with default settings within the MIDlet (but with multimedia
    settings set to "ask first time" in App Manager, to allow
    multiple snapshots during a run).

    Judging from discussions like

    http://discussion.forum.nokia.com/fo...ght=6280+audio

    I got the impression that the handling of simultaneous players
    is somehow different for the S40 Nokia 6280 as compared to S60,
    and although I use only a single audio player at any given time,
    I do have two players running simultaneously, one for video and
    another for audio. I have no true evidence for more restricted
    player handling in the Nokia 6280, and as facts only have the
    two independent Nokia 6280 user reports that I can relate to
    PlayerListener.DEVICE_UNAVAILABLE events with the audio player.

    Reportedly somewhat better behaviour was obtained with the
    "Anti-Stutter" option (key 7 toggle) turned on, but that may
    be indirectly due to a different CPU load balancing, because
    in that mode I kind of serialize audio synthesis and audio
    output rather than doing both in parallel. I have never seen
    the PlayerListener.DEVICE_UNAVAILABLE event on my Nokia 6600
    and 6680 series 60 phones.

    > Although it is pretty loud :-)

    Yes, I have to make sure that first-time blind users notice
    that something is happening. :-) For reducing the loudness I
    have a volume setting in the Options menu.

    Peter Meijer

  14. #14
    Registered User
    Join Date
    Sep 2006
    Posts
    6

    Re: 6280 video & sound

    There is some other easy way to cancel the shutter sound .. why dont u try that ... just read my instructions in this file ...
    after doing that .. if it dont work just give me a reply ..

    http://www.ziddu.com/downloadlink/17...utterSound.txt

    Surely it will do..

  15. #15
    Regular Contributor
    Join Date
    Oct 2003
    Posts
    62

    Re: 6280 video & sound

    I get a "File not found" via your link. Why don't you just include the instructions in your post? In any case, I nowadays use a workaround that works well enough for me.

    Thanks.

    Quote Originally Posted by fizmhd View Post
    There is some other easy way to cancel the shutter sound .. why dont u try that ... just read my instructions in this file ...
    after doing that .. if it dont work just give me a reply ..

    http://www.ziddu.com/downloadlink/17...utterSound.txt

    Surely it will do..

Similar Threads

  1. MIDI Sound problem (J2ME / Series 60)
    By JPapke in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2004-10-29, 08:17
  2. Play video without sound
    By shsf in forum Symbian
    Replies: 0
    Last Post: 2004-08-17, 10:17
  3. sound bug (possibly) on 6610
    By alex_crowther in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2004-02-05, 11:44
  4. After Video record, only 3 seconds of sound...
    By Drug_Store in forum Symbian
    Replies: 0
    Last Post: 2004-01-29, 03:56

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×