×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2005
    Posts
    9

    Symbian 3rd - Crash in Application Startup - possible mess in Epoch32/release/../z/ ?

    Hello,

    I use CodeWarrior 3.1

    I'm trying to compile the hellobasic example from the SDK 9.1 and changing the UID.

    I've made various attempts before getting my application successfully appeared in the 'Installation' folder.

    Now my app crash in the initialization step :

    It executes :

    Code:
    GLDEF_C TInt E32Main()
    { return EikStart::RunApplication( NewApplication ); }
    
    LOCAL_C CApaApplication* NewApplication()
    { return new CHelloWorldBasicApplication; }
    
    TUid CHelloWorldBasicApplication::AppDllUid() const
    { // Return the UID for the HelloWorldBasic application 
        return KUidHelloWorldBasicApp; }
    And crash after returning the UID ( message is : system error )

    How to debug this ? How to know what is the real error ?
    I've spend 2 days trying to understand why i can't launch my app.

    I've tried to build it from the helloworld example as well as from scartch using a framework i've done for the 2_3 & 2_2 symbian versions which works fine. In both case i've the same error.

    Also, whatever i try, my .mif icons doesn't appears.

    So far, i've not been able to compile & run successfully any programs for symbian 3rd except example - while i've done 4 symbian certified/signed app for the 2_2 & 2_3 symbian versions...

    Is it possible - by trying to compile several programs with the same uid -that i messed the registry of applications of the emulator ? How to check that the contents of the folder "installations" is correct ? How to fix it ?

  2. #2
    Super Contributor
    Join Date
    May 2003
    Location
    Vancouver, Canada
    Posts
    985

    Re: Symbian 3rd - Crash in Application Startup - possible mess in Epoch32/release/../

    Have you changed UID in all places? The UID is defined in several places and you have to change them all, i.e.:

    - MMP file (\group\helloworldbasic.mmp)
    - RSS file (\data\HelloWorldBasic_reg.rss)
    - CPP file (\src\helloworldbasicapplication.cpp)
    - PKG file (\sis\*.pkg)

    One more thing, the UID is also used in bld.inf and .cpp file to access file in \private\UID folder.

    Well, it is a bit confusing at the beginning. I am also wondering why the UID has to be defined in many different places and all of them must have the same value.

    Antony

  3. #3
    Registered User
    Join Date
    Jun 2005
    Posts
    9

    Re: Symbian 3rd - Crash in Application Startup - possible mess in Epoch32/release/../

    Yes, i've changed it correctly in all files except the .pkg file i don't use for now ( i'm trying to make it working in the emulator ) :

    The MMP file :
    Code:
    TARGET            Mooby.exe
    TARGETTYPE        exe
    UID		  0x100039CE 0x20004F30
    
    SECUREID	  0x20004F30
    EPOCSTACKSIZE	  0x5000
    
    SOURCEPATH        ..\src
    SOURCE            HelloWorldBasic.cpp
    SOURCE            HelloWorldBasicApplication.cpp
    SOURCE            HelloWorldBasicAppView.cpp
    SOURCE            HelloWorldBasicAppUi.cpp
    SOURCE            HelloWorldBasicDocument.cpp
    
    SOURCEPATH        ..\data
    
    START RESOURCE    Mooby3.rss
    HEADER
    TARGETPATH resource\apps
    END //RESOURCE
    
    START RESOURCE    Mooby3_reg.rss
    #ifdef WINSCW
    TARGETPATH 	  \private\10003a3f\apps
    #else
    TARGETPATH 	  \private\10003a3f\import\apps
    #endif
    END //RESOURCE
    The RSS Mooby3_reg.ress file :
    Code:
    #include "Mooby3.rls"
    #include <appinfo.rh>
    #include <Mooby3.rsg>
    
    UID2 KUidAppRegistrationResourceFile
    UID3 0x20004F30
    
    RESOURCE APP_REGISTRATION_INFO
      {
      app_file="Mooby";
      localisable_resource_file =  STRING_mooby_loc_resource_file_1;
      localisable_resource_id = R_MOOBY_LOCALISABLE_APP_INFO;
    
      embeddability=KAppNotEmbeddable;
      newfile=KAppDoesNotSupportNewFile;
      }
    The helloworldapplication.cpp file :

    Code:
    // UID for the application;
    // this should correspond to the uid defined in the mmp file
    const TUid KUidHelloWorldBasicApp = { 0x20004F30 };
    And it still crash :/

  4. #4
    Registered User
    Join Date
    Jun 2005
    Posts
    9

    Re: Symbian 3rd - Crash in Application Startup - possible mess in Epoch32/release/../

    Solved:

    It was, as i supposed, a mess into the emulator directories.

    The solution was to go into C:\Symbian\9.1\S60_3rd\Epoc32\release\winscw\udeb\z\private\10003a3f\apps

    , to delete all *_reg.RSC files generated by my projects ( and only them ! ), and to recompile my project after a 'Remove Object Code'.

    I guess there was a mess when the emulator was building the directory content, finding a same program name linked to different exec, or a same uid linked to different program, or another combination.

Similar Threads

  1. Phone Startup & Application Startup
    By mvadu in forum General Development Questions
    Replies: 0
    Last Post: 2006-06-21, 13:35
  2. Question about Symbian application
    By dcgiuseppe in forum Symbian
    Replies: 7
    Last Post: 2006-05-18, 11:15
  3. SDK 3rd emulator autostarts application
    By iulian_moldovan in forum Symbian
    Replies: 0
    Last Post: 2006-05-10, 07:30
  4. Running Application on UIQ 21 SDK and Symbian
    By anupamcins in forum Symbian
    Replies: 4
    Last Post: 2004-07-26, 07:24
  5. Application crash after i save the record
    By zerglim in forum Symbian
    Replies: 3
    Last Post: 2004-07-01, 07:11

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×