×

Discussion Board

Results 1 to 13 of 13
  1. #1
    Regular Contributor
    Join Date
    Jan 2005
    Location
    Estonia
    Posts
    350

    Invalid UID in Carbide vs projects

    I noticed that when I create new projects with Carbide vs.2.0.1
    the UID is set to 0x
    TARGET FDBlogger.exe
    TARGETTYPE exe
    UID 0x0 0x200033c2

    Must be:
    UID 0x100039CE 0x200033c2


    Because of that (probably) I had troubles to set my app for Symbian signing.

  2. #2
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Invalid UID in Carbide vs projects

    How did you create the offending project?

  3. #3
    Regular Contributor
    Join Date
    Jan 2005
    Location
    Estonia
    Posts
    350

    Re: Invalid UID in Carbide vs projects

    File->New->Project->Nerw Symbian OS Project., etc.

  4. #4
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Invalid UID in Carbide vs projects

    And what template and SDK target, 3.0 Maintenance release or the older one?

  5. #5
    Regular Contributor
    Join Date
    Jan 2005
    Location
    Estonia
    Posts
    350

    Re: Invalid UID in Carbide vs projects

    Project = Symbian 9
    Template = S60 3rd Ed. View Application
    SDK=S60 3.0 (9.1)

  6. #6
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Invalid UID in Carbide vs projects

    Hi,

    You are right, there seems to be a systematic error in some of the 3.0 templates for this, how on earth did it only pop up this late? Thanks for raising the issue!

    To fix, just edit the .mmp file of the offending project, the UID value is not automanaged.

    To avoid the issue in the future you can also update the templates. Go to \Carbide.vs installation dir\Templates\ProjectTemplates. For each 3.0 GUI template, locate the <template>\Group directory and edit the basename.mmp file content replacing the 0x0 UID with the correct one. For details on editing templates see Help and the document on the /doc directory.

    What exactly were the problems you got with signing?

  7. #7
    Regular Contributor
    Join Date
    Jan 2005
    Location
    Estonia
    Posts
    350

    Re: Invalid UID in Carbide vs projects

    Quote Originally Posted by mitts
    What exactly were the problems you got with signing?
    The web gave error that my sis package contains some bizzarre UID (0x3...).
    I'm 99.99% sure that I have never used this kind of numbers.
    I have sent my files to Symbiansigned to investigate and they found this error in my MMP.
    I don't know if it is actually causing it, 'cause I haven't resubmitted my files yet.

  8. #8
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Invalid UID in Carbide vs projects

    I would appreciate it if you posted a follow-up if/when you resubmit so we know the full picture here! Thanks.

  9. #9
    Regular Contributor
    Join Date
    Jan 2005
    Location
    Estonia
    Posts
    350

    Re: Invalid UID in Carbide vs projects

    Seems that now the submitting worked

  10. #10
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Invalid UID in Carbide vs projects

    Thanks for the update. I take it to mean that the only thing you fixed was the UID2 value?

  11. #11
    Regular Contributor
    Join Date
    Jan 2005
    Location
    Estonia
    Posts
    350

    Re: Invalid UID in Carbide vs projects

    Yes (at least knowingly

  12. #12
    Super Contributor
    Join Date
    Sep 2004
    Posts
    1,048

    Re: Invalid UID in Carbide vs projects

    Cool, thanks!

  13. #13
    Registered User
    Join Date
    Mar 2003
    Location
    Germany
    Posts
    200

    Re: Invalid UID in Carbide vs projects

    Quote Originally Posted by rihoe
    I noticed that when I create new projects with Carbide vs.2.0.1
    the UID is set to 0x
    UID 0x0 0x200033c2

    Must be:
    UID 0x100039CE 0x200033c2
    On a related note: 0x100039CE is the correct UID2 value for a GUI application, but what is the recommended value to use for a non-GUI server in 3rd Edition, where the old convention of leaving it 0 no longer works, at least for Symbian Signed executables?

    Should 0x100039CE now be used for any EXE file, regardless of its type?

Similar Threads

  1. Recording in Amr Format
    By losym in forum Symbian Media (Closed)
    Replies: 12
    Last Post: 2009-03-26, 06:41
  2. Import\Export Project Problem in Carbide
    By mohsin.sohail in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 4
    Last Post: 2006-07-17, 20:20
  3. Question on Importing Projects into Carbide
    By d2army in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2006-06-22, 19:13
  4. Question on Importing Projects into Carbide
    By d2army in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2006-06-22, 02:02
  5. Midlet's uid, Symbian 3rd edition
    By viktor_m in forum Symbian
    Replies: 0
    Last Post: 2006-03-06, 10:15

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×