×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    224

    Angry Midlet and WAP access point!!!

    Hi guys,

    I have trying to solve the problem of using WAP access point from MIDLET. I tried several 3rd party professional application which uses internet. When I choose WAP access point, application just hangs. It happens for all the applications. If I choose Internet access point all the applications work. I tried to run the application in NokiaN70 (Series 60, symbian 8.1), WAP access point works in this device.

    Is it so that older nokia phones do not support WAP access point from MIDLET. I am really confused with this problem. I really hope some Nokia experts give comment on this.
    Regards,
    shagor

  2. #2
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    Re: Midlet and WAP access point!!!

    I don't think it's a good idea to keep on repeating in new posts...
    however, I've the same problem and not solved yet.
    I'm managing to use Sockets instead of HttpConnection and change my server port from 8080 to 8585 (because Socket block 80 and 8080 if not midlet is not signed).

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    224

    Thumbs down Re: Midlet and WAP access point!!!

    Hi thecloud,

    First of all, it's not the same question. It's a related topic. Please read the whole topicbefore making an unpleasant comment. In this topic, I discussed about how I got my WAP and MIDLET working on NokiaN70. So I asked whether it is the devices issue with Midlet and WAP.

    One other thing, if HttpConnection doesn't work with WAP access point, most probably Socket doesn't help.
    Regards,
    shagor

  4. #4
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    Re: Midlet and WAP access point!!!

    Quote Originally Posted by khurshed79
    Hi thecloud, <cut>
    In this topic, I discussed about how I got my WAP and MIDLET working on NokiaN70. So I asked whether it is the devices issue with Midlet and WAP.
    Another user on recent previous posts (3-4 lines under) reported also N70 to work on Wap connected midlet.

    Quote Originally Posted by khurshed79
    One other thing, if HttpConnection doesn't work with WAP access point, most probably Socket doesn't help.
    Another user on older previous posts reported NOK660 to work on wap connection using Socket implementing HTTP manually.
    It should not work theorically, but on theese phone, what is theorically true ?
    Another user reported to use the correct permission in the jad file about javax.....http would solve this (not for me)
    Another user reported is due to kind of protocol differences between wsp and http, but this it theorically wrong on HttpConnections.

    Quote Originally Posted by khurshed79
    First of all, it's not the same question. It's a related topic. Please read the whole topicbefore making an unpleasant comment.
    Excuse me then, I wouldn't liked to be aggressive, I haven't catch it was specifically on N70; I'm also waiting for suggestions to go around the wap problem.

    Cheers
    Julien

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    33

    Re: Midlet and WAP access point!!!

    I've implemented http with socket on 6600, reconfigured my webserver to listen on port 8585 (as socket is not allowed on port 80 and 8080 for non trusted midlets) and I can firmly confirm that is not working on 6600 and on 9500 WAP APN.

  6. #6
    Regular Contributor
    Join Date
    Mar 2003
    Location
    Finland
    Posts
    224

    Angry Re: Midlet and WAP access point!!!

    Hi thecloud,

    I've implemented http with socket on 6600, reconfigured my webserver to listen on port 8585 (as socket is not allowed on port 80 and 8080 for non trusted midlets) and I can firmly confirm that is not working on 6600 and on 9500 WAP APN.
    I already knew that socket would not help in this case. When we use HttpConnection class, it means we use socket. HttpConnection class is implented on socket. So basically our problem does not lie at this point. I hope some Nokia expert tell us more about this Midlet and WAP this. This is a very important issue. Most of the operators have implemented WAP billing system. So it's important for the Midlet developers for taking the advantage of WAP billing.
    Regards,
    shagor

Similar Threads

  1. Connecting J2ME application to Internet using WAP access point?
    By khurshed79 in forum Mobile Java Networking & Messaging & Security
    Replies: 12
    Last Post: 2012-09-12, 09:53
  2. Bug in E61 Java networking prompts user for access point per connection
    By j.storey in forum Mobile Java Networking & Messaging & Security
    Replies: 10
    Last Post: 2007-09-27, 14:57
  3. 6600 + WAP Access Point = NO Internet?
    By tzihx2 in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2005-05-11, 15:23
  4. Midlet connecting via internet APN instead of WAP APN
    By roarl in forum Mobile Java General
    Replies: 1
    Last Post: 1970-01-01, 02:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×