×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,673

    WIDCOMM SDK/driver does not accept RFCOMM connection (S60)

    Hi, I have a not-exactly-Nokia-related problem, but someone may know the answer.

    I have made a Series 60 client (C++, compiled with 2nd edition 2.1, tested on 6600 and 6630) for the BlueChat example included in the WIDCOMM BT SDK. I can browse the SDP (get its name, the channel, etc.), and the phone also believes that it can connect to the service (returns no error, and it even believes that it can send data to the service - with also no sign of an error). The problem is that the PC-side does not sense the connection-attempt (nor the data transmission).
    So, I decided to try a server on the phone. And it works: the (still unmodified) BlueChat application can connect to the S60 chat-service, and my client can also connect to it.
    And of course 2 PC-based BlueChat applications can also cooperate.

    Has anyone seen something similar before? I have tried to search this sub-forum but most WIDCOMM-hits are about file-transfer and PC-Suite.

    My client can connect to the PC if I replace the WIDCOMM-drivers + BlueChat with a socket-based application using the Microsoft BT stack.

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,673

    Re: WIDCOMM SDK/driver does not accept RFCOMM connection (S60)

    OK, I have just received the answer in my other related post.

    If you are interested, the service name has to be modified:
    Code:
    static char m_serviceNameForServer[BT_MAX_SERVICE_NAME_LEN + 1] = "Bluetooth Serial Port";
    (it has been "WIDCOMM SDK RFComm Service" by default), and everything starts to work.
    It is really nice to know that in the beautiful Bluetooth world of GUIDs and UIDs, a simple textual string can decide if something works or not.

Similar Threads

  1. HTTP Connection in S60 Simulator, Problem?
    By photonman in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2003-08-29, 22:10
  2. HTTP connection on 6310i, 7650, 9210 and in sony-ericsson p800
    By mika1982 in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2003-07-24, 16:44
  3. Nokia 3585i and PC Suite 4.95; NO CONNECTION
    By chrism2202 in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2003-04-21, 12:10
  4. Replies: 5
    Last Post: 2003-02-07, 11:25
  5. S60 socket connection, can send but cannot receive
    By tangxj in forum Mobile Java General
    Replies: 2
    Last Post: 2002-09-04, 15:39

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×