×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Dec 2005
    Posts
    7

    running OpenGL ES in N93

    Hi!

    My OpenGL ES application works fine in the emulator, but when I run it on N93 the appication exits during startup with "menu: feature not supported". I traced it down to glBindBuffer. When I remove it from my program everything works fine! N93 should be OpenGL ES 1.1 complient and glBindBuffer is part of 1.1 or not?

    Also the FloatingDuck example shipped with the OpenGL ES 1.1 plugin has this problem.

    thanks
    Hubert


    It is me again. I worked around the issue by not using FBOs and glBindBuffer, but I still wonder why it does not work! If Nokia claims that the phone is OpenGl ES 1.1 compliant glBindBuffer should work! Did anyone run the conformance tests? http://www.khronos.org/opengles/adopters

    Anyway, I am very impressed by the performance of the N93. Really cool :-)
    Last edited by derBertl; 2006-08-29 at 16:56.

  2. #2
    Registered User
    Join Date
    Oct 2006
    Posts
    1

    Re: running OpenGL ES in N93

    Well, it seems we have the same problem. This message "menu: function not supported" means that the requested function cannot be found in the opengl dll. I`m still searching for the real opengl 1.1 dll for my n93. I was on the PowerVr website and have downloaded the sdk`s for symbian, but the new dll was not found . It seems n93 is running only with opengl 1.0. Another issue that kills me is the support of only 16-bit depth buffer against the 4x ANTI - Aleizing . As a result I have lots of graphical mistakes due the low depth buffer precision. On my old siemens sx1 I have used the opengles 1.1 from hybrid graphics. Just perfect...but...too slow ... but really fast for a sw renderer. Now I have great performance but bad image quality and no opengles 1.1 support AND the worst OS I have ever seen in my 10 years programming practice. Just cool, dear Nokia, just do it in that way and you will loose all your developers. Windows is coming... God bless Windows Mobile!

  3. #3
    Nokia Developer Expert
    Join Date
    Mar 2003
    Posts
    68

    Re: running OpenGL ES in N93

    Check the sticky topic on the top of this forum to solve the "feature not supported" error. The issue is with the SDK plugin, not the device itself. N93 has fully HW accelerated OpenGL ES 1.1.

    Jani Vaarala
    Graphics Architect
    Nokia

  4. #4
    Registered User
    Join Date
    Sep 2006
    Posts
    29

    Re: running OpenGL ES in N93

    Quote Originally Posted by boriskamenov
    Another issue that kills me is the support of only 16-bit depth buffer against the 4x ANTI - Aleizing . As a result I have lots of graphical mistakes due the low depth buffer precision.
    Could you give some more details on this? Are you saying that there is no EGL config with EGL_SAMPLES == 4 and EGL_DEPTH_SIZE > 16? I'd be very surprised if that's the case as there is no technical reason for such a limitation.

Similar Threads

  1. breakpoints disabled when running debugger.
    By nawkboy in forum Symbian
    Replies: 4
    Last Post: 2012-05-31, 10:45
  2. N93 clock
    By eronald in forum Symbian
    Replies: 4
    Last Post: 2006-09-01, 01:32
  3. Help Running the OpenGL examples (3rd ed.)
    By fabiano_pmj in forum Symbian
    Replies: 6
    Last Post: 2006-04-05, 09:50
  4. Replies: 1
    Last Post: 2003-09-08, 12:58
  5. breakpoints disabled when running debugger
    By nawkboy in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2003-02-20, 03:43

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×